Win10论坛

Win10正式版系统下载主题平板

重定义Modern UI,打造完美Windows全新体验

Windows10下载|安装|新手宝典|必备软件

搜索
查看: 6276|回复: 17

[求助] 美版Y410P黑苹果HD4600驱动不了,求大神指点 [复制链接]

Rank: 1

UID
2434750
帖子
28
PB币
42
贡献
0
技术
16
活跃
22
发表于 2014-1-25 10:46:27 |显示全部楼层
电脑配置如下:
处理器            英特尔 Core i7-4700MQ @ 2.40GHz 四核
  主板              联想 VIQY0Y1 (英特尔 Haswell)
  内存              8 GB ( 记忆科技 DDR3L 1600MHz )
  主硬盘            希捷 ST1000LM024 HN-M101MBB ( 1 TB / 5400 转/分 )
  显卡              Nvidia GeForce GT 755M ( 2 GB / 联想 )
  显示器            友达 AUO203E ( 14 英寸 )
  光驱              松下 DVD-RAM UJ8DB DVD刻录机
  声卡              瑞昱 Realtek @ 英特尔 Lynx Point 高保真音频
  网卡              鈺硕 QCA8171 Gigabit Ethernet / 联想
--------[ 显卡 ]----------------------------------------------------------------------------------
显卡              英特尔 Haswell Integrated Graphics Controller
  显存              2112 MB
  制造商            联想
  BIOS版本          Intel Video BIOS
  BIOS日期          01/11/20
  驱动版本          9.18.10.3165
  驱动日期          5-7-2013
  主显卡            Nvidia GeForce GT 755M
  显存              2 GB
  制造商            联想
  BIOS日期          01/11/20
  驱动版本          9.18.13.1154
  驱动日期          4-14-2013
--------[ 网卡 ]----------------------------------------------------------------------------------
  网卡              鈺硕 QCA8171 Gigabit Ethernet
  制造商            联想
  无线网卡          英特尔 Centrino Wireless-N 2230 BGN


电脑是美版无SSD卡的高份屏Y410P,根据论坛的贴子已经装了10.9.1懒人镜像版,安装过程还算顺利,但就是驱动太折磨人了(论坛也爬了好久,已经几个晚上凌晨才睡了),最重要的显卡驱动不了,屏幕总是闪,问题主要是:
1、MAC版变色龙引导,不能加入GRAPHENABER=YES项,只要有这项启动迅速提示INVIDA ROM错误,但是BIOS比较简单,不能屏蔽独显。
2、用DSDT注入的方法试了两个AAPL,ig-platform-id码都不行。


屏幕快照 2014-01-25 上午3.14.28.png


屏幕快照 2014-01-25 上午3.14.43.png


屏幕快照 2014-01-25 上午3.14.12.png





现将DSDT上传,求修改。
屏幕快照 2014-01-25 上午4.09.14.png
屏幕快照 2014-01-25 上午4.09.05.png

Rank: 1

UID
2434750
帖子
28
PB币
42
贡献
0
技术
16
活跃
22
发表于 2014-1-25 10:50:33 |显示全部楼层
本帖最后由 mfileon 于 2014-1-25 12:02 编辑

最后两张图是不知道用什么原因,出来的两个显卡,system info里居然也提示两个显卡,是不是有可能两个都驱动?

还有显卡驱动不上与我删除了SLE所有INTEL显卡驱动有关吗?

美版Y410P DSDT.rar

16 KB, 下载次数: 35, 下载积分: PB币 -1

Rank: 1

UID
2434750
帖子
28
PB币
42
贡献
0
技术
16
活跃
22
发表于 2014-1-25 11:58:22 |显示全部楼层
自己顶上去,心情急迫啊

求71狐狸尾巴当抱枕......外出南极洲旅游至今未归

UID
2881599
帖子
18661
PB币
94482
贡献
1
技术
23515
活跃
2821

热心会员 8周年庆典勋章

发表于 2014-1-25 11:59:50 |显示全部楼层
两个都驱动是不可能的
把SLE下的NV显卡驱动全删掉
Chameleon Wizard 设置 Boot.plist 里 Intel Azul FB = 12 试试 好像是12 具体看置顶集合贴V2.0 Beta16里的 Haswell 核显驱动部分

Rank: 1

UID
2434750
帖子
28
PB币
42
贡献
0
技术
16
活跃
22
发表于 2014-1-25 12:04:16 |显示全部楼层
neycwby09 发表于 2014-1-25 11:59
两个都驱动是不可能的
把SLE下的NV显卡驱动全删掉
Chameleon Wizard 设置 Boot.plist 里 Intel Azul FB = ...

谢谢回复,没有GRAPHICSENABER=YES选项能直接用后面的GRAPHENABER=YES吗?
我的是2344版

求71狐狸尾巴当抱枕......外出南极洲旅游至今未归

UID
2881599
帖子
18661
PB币
94482
贡献
1
技术
23515
活跃
2821

热心会员 8周年庆典勋章

发表于 2014-1-25 12:07:14 |显示全部楼层
mfileon 发表于 2014-1-25 12:04
谢谢回复,没有GRAPHICSENABER=YES选项能直接用后面的GRAPHENABER=YES吗?
我的是2344版

这个 显卡注入 选项只有一个吧。。。。

你是不是记错拼写了。。。

Graphics Enabler = YES
在Mac下可以用 Chameleon Wizard 方便地修改 com.chameleon.Boot.plist 的。。。
具体可以在 置顶集合贴 V2.0 Beta16 里下载

听不懂广东话的人

Rank: 5Rank: 5Rank: 5

UID
732355
帖子
538
PB币
2273
贡献
0
技术
50
活跃
513

8周年庆典勋章

发表于 2014-1-25 12:20:34 |显示全部楼层

Rank: 2Rank: 2

UID
3166365
帖子
180
PB币
309
贡献
0
技术
3
活跃
719
发表于 2014-1-25 12:24:41 |显示全部楼层
朋友在吗?我的也是Y410P就是没安装上,不知道那个环节出问题了,你看的是哪个帖子安装成功的,告诉我一下!

Rank: 1

UID
2434750
帖子
28
PB币
42
贡献
0
技术
16
活跃
22
发表于 2014-1-25 12:44:11 |显示全部楼层
624999521 发表于 2014-1-25 12:24
朋友在吗?我的也是Y410P就是没安装上,不知道那个环节出问题了,你看的是哪个帖子安装成功的,告诉我一下! ...

抛砖引玉 410p啃上黑苹果那个贴子,你搜一下,没刷BIOS用的打过补丁的内核

Rank: 1

UID
2434750
帖子
28
PB币
42
贡献
0
技术
16
活跃
22
发表于 2014-1-25 12:47:55 |显示全部楼层
长颈鹿 发表于 2014-1-25 12:20
FYI
http://bbs.pcbeta.com/viewthread-1450409-1-1.html

我就是按那个贴子安装的,用的EXTRA与DSDT,但是显卡还是不行。

Rank: 2Rank: 2

UID
3166365
帖子
180
PB币
309
贡献
0
技术
3
活跃
719
发表于 2014-1-25 12:49:50 |显示全部楼层
mfileon 发表于 2014-1-25 12:47
我就是按那个贴子安装的,用的EXTRA与DSDT,但是显卡还是不行。

我刚才还试着装了一遍,读取完文件就自动重启了,我去看看那个帖子。

Rank: 1

UID
2434750
帖子
28
PB币
42
贡献
0
技术
16
活跃
22
发表于 2014-1-25 12:58:57 |显示全部楼层
624999521 发表于 2014-1-25 12:49
我刚才还试着装了一遍,读取完文件就自动重启了,我去看看那个帖子。

我原来也是自动重启,装完你要把内存替换到安装盘里,剩下的就是删除一些驱动的事了,你要成功了看看显卡有没有驱动上

Rank: 1

UID
2434750
帖子
28
PB币
42
贡献
0
技术
16
活跃
22
发表于 2014-1-25 17:26:05 |显示全部楼层
继续求帮助,呵呵!

Rank: 1

UID
2434750
帖子
28
PB币
42
贡献
0
技术
16
活跃
22
发表于 2014-1-25 22:17:48 |显示全部楼层
顶上去,有没有驱动成功的人告知一下要保留关于INTEL显卡哪些驱动,因为错误我已基本上都删除了只保留了appleintelHDgraphic与appleintelHDgraphicsGLDdriver两个文件.如果加载appleintelbufferazul就直接黑屏

求71狐狸尾巴当抱枕......外出南极洲旅游至今未归

UID
2881599
帖子
18661
PB币
94482
贡献
1
技术
23515
活跃
2821

热心会员 8周年庆典勋章

发表于 2014-1-26 00:00:20 |显示全部楼层
mfileon 发表于 2014-1-25 22:17
顶上去,有没有驱动成功的人告知一下要保留关于INTEL显卡哪些驱动,因为错误我已基本上都删除了只保留了app ...

我去了  你把核显驱动都快删没了 能驱上就怪了。。。。

把完整的核显kext安装到SLE去 自己参照 http://bbs.pcbeta.com/viewthread-1465761-1-1.html 这个贴 设置

实在不行 改DSDT注入ig-platform-id   认真看那个帖子

Rank: 1

UID
4368221
帖子
15
PB币
88
贡献
0
技术
16
活跃
45
发表于 2014-2-4 21:21:57 |显示全部楼层
楼主跟我情况雷同啊,我也是i7  4700mq,删的只剩一个Intelhd5000.kext系统识别为hd5000驱动不了,我的独显是GT750M跟你一样也在系统信息里能看到,
我也正发愁HD4600的驱动,不知道楼主弄好了没,我要是弄好了告诉你

Rank: 2Rank: 2

UID
2299633
帖子
263
PB币
227
贡献
0
技术
2
活跃
348
发表于 2014-2-4 21:25:38 |显示全部楼层
神船i7 发表于 2014-2-4 21:21
楼主跟我情况雷同啊,我也是i7  4700mq,删的只剩一个Intelhd5000.kext系统识别为hd5000驱动不了,我的独显是G ...

改dsdt我的可以驱动,水波纹也正常,现在就是启后进入桌面花屏,要注销后才能正常显示,还在找原因。
HDMI输出和AirPlay都正常。

http://bbs.pcbeta.com/viewthread-1474139-1-1.html

Rank: 1

UID
4368221
帖子
15
PB币
88
贡献
0
技术
16
活跃
45
发表于 2014-2-4 21:30:38 |显示全部楼层
hs9206 发表于 2014-2-4 21:25
改dsdt我的可以驱动,水波纹也正常,现在就是启后进入桌面花屏,要注销后才能正常显示,还在找原因。
HD ...

是不是吧Intelhd什么的驱动全复制回去了?,变色龙graphics enabler要加吗
回顶部
Copyright (C) 2005-2020 pcbeta.com, All rights reserved
Powered by Discuz!  苏ICP备17027154号
请勿发布违反中华人民共和国法律法规的言论,会员观点不代表远景论坛官方立场。
远景在线 | 远景论坛 | 苹果论坛 | Win10论坛 | Win8论坛 | Win7论坛 | WP论坛 | Office论坛 | 电脑硬件 | 安卓软件