Win10论坛

Win10正式版系统下载主题平板

重定义Modern UI,打造完美Windows全新体验

Windows10下载|安装|新手宝典|必备软件

搜索
查看: 8322|回复: 12

[核显] 解决HD4600/P4600开机最后阶段8个苹果花屏(亲测) [复制链接]

Rank: 2Rank: 2

UID
1036935
帖子
117
PB币
156
贡献
0
技术
0
活跃
210
发表于 2018-4-10 15:14:48 |显示全部楼层

该问题应该为分辨率加载不正确引起。也就是在加载Clover时没提供正确的分辨率给系统出现的闪屏现象,我的8个苹果花屏现象黑苹果一直都有,其实并不影响使用。当然,强迫症者希望可以解决。下面提供个人解决方法。不保证所有配置适用。

在正常驱动显卡后,只需要改动一个地方即可。使用Clover Configurator打开配置文件,更改Gui项目的分辨率为你使用的显示器的物理分辨率,重启即可。

另外,看我的显卡驱动,代码都没有定义,Other里面也是放了最基本的,我用的驱动都是放在Other里面,全部驱动如图,不像大多数说的要放什么,其实绝大部分都是没有必要的驱动个,(比如HD4400只需要添加配置代码,不用放kext文件就能正确驱动,但是放来显卡驱动进去搞来搞去驱动不了)我连USB驱动也没用,但是USB一切都正常,拷贝150多M的速度)总之,不明确作用的kext文件反而会出现许多不可预料的问题产生,不是越多越好,而是越少越好。我的配置现在是完美使用中的。

CPU:1285L V3  变频正常
内存:8G DDR3 1600
显卡:P4600  加速什么的都正常
显示器:2K,HDMI+DP+DVI都可以(并且有声音输出)
有线网卡:英特尔i217LM
无线网卡:94360,蓝牙4.0  接力,隔空投送,imessage都正常
声卡:ALC无解的用万能驱动    现用DP连接声音正常
睡眠:唤醒或者睡眠都正常
鼠标:开机没卡顿现象
USB:前后接口都正常使用(2.0   3.0都是)


附件: 你需要登录才可以下载或查看附件。没有帐号?注册
1

查看全部评分

Rank: 1

UID
4839092
帖子
51
PB币
209
贡献
0
技术
3
活跃
57
发表于 2018-4-10 16:24:52 |显示全部楼层
感谢楼主分享
我的Config设置和楼主基本一样,升到10.13.4没有8苹果和花屏了。
以前在10.13.3各种花,网页都花

Rank: 2Rank: 2

UID
4829908
帖子
360
PB币
69
贡献
0
技术
0
活跃
640
发表于 2018-4-10 16:31:46 |显示全部楼层
hd530依然花,4k分辨率

Rank: 2Rank: 2

UID
1036935
帖子
117
PB币
156
贡献
0
技术
0
活跃
210
发表于 2018-4-10 16:39:47 |显示全部楼层
yaozaiyu 发表于 2018-4-10 16:31
hd530依然花,4k分辨率

我的不花了。黑苹果以来第一次解决该问题。可能是你的核显驱动混乱(比如使用太多驱动文件和配置文件定义了)

Rank: 2Rank: 2

UID
1036935
帖子
117
PB币
156
贡献
0
技术
0
活跃
210
发表于 2018-4-10 16:41:34 |显示全部楼层
yaozaiyu 发表于 2018-4-10 16:31
hd530依然花,4k分辨率

尝试下,看是否驱动态混乱导致

Rank: 9

UID
750326
帖子
4142
PB币
2740
贡献
0
技术
102
活跃
2401
发表于 2018-4-10 16:43:13 来自手机 |显示全部楼层
我回去也试试

ASlien

Rank: 5Rank: 5Rank: 5

UID
3032997
帖子
615
PB币
659
贡献
0
技术
2
活跃
715
发表于 2018-4-10 17:16:16 |显示全部楼层
本帖最后由 wenjian065 于 2018-4-10 17:17 编辑

最好的办法还是注入 id 比较完美,然后 fake injet

点评

wenjian065  那是能用,但是完美的亮度和显示这样才靠谱  发表于 2018-4-11 17:34
athlonreg  id在好久之前就免了,貌似4600 4400这些只需要两个kext和侦测  发表于 2018-4-10 17:26

Rank: 5Rank: 5Rank: 5

UID
771963
帖子
597
PB币
1064
贡献
0
技术
0
活跃
2006
发表于 2018-4-10 18:10:58 |显示全部楼层
kyou2003 发表于 2018-4-10 16:39
我的不花了。黑苹果以来第一次解决该问题。可能是你的核显驱动混乱(比如使用太多驱动文件和配置文件定义 ...

你是不是纯UEFI启动,也就是有没在BIOS里彻底关闭CSM启动?
听说如果CSM是打开的就不会8苹果,纯UEFI的话还是无解,,,听说。。。

Rank: 5Rank: 5Rank: 5

UID
4611925
帖子
440
PB币
430
贡献
0
技术
5
活跃
373
发表于 2018-4-10 19:12:08 |显示全部楼层
指有你 发表于 2018-4-10 18:10
你是不是纯UEFI启动,也就是有没在BIOS里彻底关闭CSM启动?
听说如果CSM是打开的就不会8苹果,纯UEFI的话 ...

我现在就是这种情况,mbr时都正常,换成纯uefi就8个苹果+花屏,睡眠一下才恢复正常。

Rank: 2Rank: 2

UID
4217016
帖子
211
PB币
133
贡献
0
技术
0
活跃
440
发表于 2018-4-11 15:26:18 |显示全部楼层
13.2和12.5,12.6试过了,开启CSM或者改分辨率为1280*720可以解决,改为1080就花屏,并且现在很多懒人版的clover配置里面分辨率就是自适应为电脑的物理分辨率的,你可以试试拿笔记本来看看有没有解决

Rank: 7Rank: 7Rank: 7

UID
4660277
帖子
3426
PB币
3783
贡献
0
技术
7
活跃
1723
发表于 2018-4-12 07:56:39 |显示全部楼层
学习了,谢谢分享。

Rank: 5Rank: 5Rank: 5

UID
4773321
帖子
974
PB币
170
贡献
0
技术
0
活跃
1090
发表于 2018-9-17 11:48:05 |显示全部楼层
学习一下,谢谢楼主

Rank: 1

UID
3134801
帖子
6
PB币
18
贡献
0
技术
0
活跃
23
发表于 2019-4-16 23:11:39 |显示全部楼层
赞!👍。我降低了分辨率,果然可以了。晕。屏幕改主板都没有用啊!~~~
回顶部
Copyright (C) 2005-2021 pcbeta.com, All rights reserved
Powered by Discuz!  苏ICP备17027154号
请勿发布违反中华人民共和国法律法规的言论,会员观点不代表远景论坛官方立场。
远景在线 | 远景论坛 | 苹果论坛 | Win10论坛 | Win8论坛 | Win7论坛 | WP论坛 | Office论坛 | 电脑硬件 | 安卓软件