Win10论坛

Win10正式版系统下载主题平板

重定义Modern UI,打造完美Windows全新体验

Windows10下载|安装|新手宝典|必备软件

搜索
查看: 3268|回复: 74

[声卡] Acer E5 575g I5 7200U HD620 安装Mojave 整理分享EFI [复制链接]

Rank: 2Rank: 2

UID
4796485
帖子
229
PB币
180
贡献
0
技术
0
活跃
307
发表于 2019-2-21 15:33:59 |显示全部楼层
本帖最后由 魂牵梦Mong 于 2020-2-25 17:03 编辑

Acer E5 575g I5 7200U HD620 成功安装macOS Mojave 整理EFI分享


笔记本配置如下;

电脑型号            Aspire E5-575G 笔记本电脑

操作系统            Windows 10 专业版+macOS High Sierra 双系统

处理器              英特尔 Core i5-7200U @ 2.50GHz 双核

主板                宏碁 Ironman_SK ( 7th Generation Intel Processor Family I/O - 9D58 笔记本芯片组 )

显卡                Nvidia GeForce 940MX ( 2 GB / 宏碁 )

内存                8 GB ( 海力士 DDR4 2400MHz ) 升级内存

主硬盘               HP SSD EX900 250GB ( 250 GB / 固态硬盘 ) 升级固态

显示器              京东方 BOE06F1 ( 15.5 英寸  )更换1080p高分屏

声卡                瑞昱  @ 英特尔 High Definition Audio 控制器

网卡                博通 Broadcom 802.11ac Network Adapter  拆机更换为BCM94352Z网卡


使用的是黑果小兵的镜像  原帖链接【黑果小兵】macOS Mojave 10.14.2(18C54)正式版 with Clover 4792原版镜像


一开始下载的是最新10.14.3的镜像 但奈何安装进入系统页面时键盘不能使用 于是爬贴 下载了10.14.2 dmg镜像 一路顺利安装成功。 接下来折腾驱动以及补丁patch ,经过2天多的爬贴折腾,完成情况还不错


以下是完成情况:

· HDMI 音频输出正常

· HDMI 视频输出正常,可以正常切换不黑屏

· 三个USB接口正常

· 核显HD620成功驱动

· 电源工作正常,电池也正常显示

· 声卡ALC255内建成功

· 博通网卡BCM94352Z正常驱动 蓝牙正常使用

· 触摸板可用

· Fn快捷键 声音大小可调

· 插电源休眠唤醒正常,电池无法正常睡眠 作用不大 平时一般都是插着电源用

· Siri 、麦克风已及定位正常使用

· FaceTime 通话正常、AppleAPP store 正常登陆

7档变频









最后分享EFI文件





附件: 你需要登录才可以下载或查看附件。没有帐号?注册

Rank: 2Rank: 2

UID
4796485
帖子
229
PB币
180
贡献
0
技术
0
活跃
307
发表于 2019-2-23 11:27:24 |显示全部楼层
前排留位

Rank: 2Rank: 2

UID
2728712
帖子
252
PB币
5
贡献
0
技术
0
活跃
430
发表于 2019-2-24 08:23:17 |显示全部楼层
感谢楼主分享,我自己总是搞出莫名其妙的问题,用你的 efi 文件夹,直接一步到位了。你的声卡问题,我用了 codecommander 也不管用,正在研究声卡仿冒的节点什么的,就是按照黑锅小兵的教程,希望有用。

Rank: 2Rank: 2

UID
2728712
帖子
252
PB币
5
贡献
0
技术
0
活跃
430
发表于 2019-2-24 17:01:56 |显示全部楼层
zjt3000 发表于 2019-2-24 08:23
感谢楼主分享,我自己总是搞出莫名其妙的问题,用你的 efi 文件夹,直接一步到位了。你的声卡问题,我用了  ...

当我按照教程搞了一天才搞了一半,都想死了的时候,我突然发现声音好了,没有电流声了。。。不知道是什么行为起效果了。
我建议换一个新版本的 applealc.kext 试试吧。

Rank: 2Rank: 2

UID
4796485
帖子
229
PB币
180
贡献
0
技术
0
活跃
307
发表于 2019-2-24 19:23:02 |显示全部楼层
zjt3000 发表于 2019-2-24 17:01
当我按照教程搞了一天才搞了一半,都想死了的时候,我突然发现声音好了,没有电流声了。。。不知道是什么 ...

耳机声音正常吗?
我的外放声音正常的 就是耳机声音不行

Rank: 2Rank: 2

UID
4260090
帖子
295
PB币
1
贡献
0
技术
0
活跃
134
发表于 2019-2-24 19:59:05 |显示全部楼层
感谢楼主分享,我自己总是搞出莫名其妙的问题,用你的 efi 文件夹,直接一步到位了。你的声卡问题,我用了 codecommander

Rank: 2Rank: 2

UID
4260090
帖子
295
PB币
1
贡献
0
技术
0
活跃
134
发表于 2019-2-24 19:59:46 |显示全部楼层
耳机声音正常吗?
我的外放声音正常的 就是耳机声音

Rank: 2Rank: 2

UID
2728712
帖子
252
PB币
5
贡献
0
技术
0
活跃
430
发表于 2019-2-24 20:43:19 |显示全部楼层
魂牵梦Mong 发表于 2019-2-24 19:23
耳机声音正常吗?
我的外放声音正常的 就是耳机声音不行

现在都 ok,我一开始也是耳机不行,后来不知道怎么好了。

Rank: 2Rank: 2

UID
4796485
帖子
229
PB币
180
贡献
0
技术
0
活跃
307
发表于 2019-2-25 18:34:06 |显示全部楼层
zjt3000 发表于 2019-2-24 20:43
现在都 ok,我一开始也是耳机不行,后来不知道怎么好了。

用的是我的efi文件和驱动的吗?clover注入layout id 没有改吗?

如果能正常用的话 可能我的Alc255声卡比较奇葩吧

Rank: 2Rank: 2

UID
2853684
帖子
445
PB币
269
贡献
0
技术
0
活跃
438
发表于 2019-2-25 19:01:13 |显示全部楼层
魂牵梦Mong 发表于 2019-2-25 18:34
用的是我的efi文件和驱动的吗?clover注入layout id 没有改吗?

如果能正常用的话 可能我的Alc255声卡 ...

看我的签名  咱俩电脑配置一样  我注入的ID是3  你可以试试

Rank: 2Rank: 2

UID
2853684
帖子
445
PB币
269
贡献
0
技术
0
活跃
438
发表于 2019-2-25 19:01:44 |显示全部楼层
魂牵梦Mong 发表于 2019-2-25 18:34
用的是我的efi文件和驱动的吗?clover注入layout id 没有改吗?

如果能正常用的话 可能我的Alc255声卡 ...

我的github地址:https://github.com/ysx25261465/Acer-TravelMate-TX40-G2

有时间可以研究下

Rank: 2Rank: 2

UID
4796485
帖子
229
PB币
180
贡献
0
技术
0
活跃
307
发表于 2019-2-25 19:13:30 |显示全部楼层
ysx25261465 发表于 2019-2-25 19:01
看我的签名  咱俩电脑配置一样  我注入的ID是3  你可以试试



现在我也是注入id 3  耳机还是有背景音,可能是驱动文件不能用吧
能分享一下你的efi吗?
附件: 你需要登录才可以下载或查看附件。没有帐号?注册

Rank: 2Rank: 2

UID
2728712
帖子
252
PB币
5
贡献
0
技术
0
活跃
430
发表于 2019-2-25 19:54:24 |显示全部楼层
魂牵梦Mong 发表于 2019-2-25 18:34
用的是我的efi文件和驱动的吗?clover注入layout id 没有改吗?

如果能正常用的话 可能我的Alc255声卡 ...

我建议:更新各个驱动,加入 codecomander,多重启几次,还是不行就换换别人的 efi 试试。我反正就是这么干的。我自己搞的话,总是有各种问题。你的 efi 已经很不错了。不行的话,附件是我现在的 efi 文件夹里的东西,因为权限就分开发了,你看看吧,基本都是根据你的 efi 来的。
附件: 你需要登录才可以下载或查看附件。没有帐号?注册

Rank: 2Rank: 2

UID
4796485
帖子
229
PB币
180
贡献
0
技术
0
活跃
307
发表于 2019-2-25 19:56:15 |显示全部楼层
zjt3000 发表于 2019-2-25 19:54
我建议:更新各个驱动,加入 codecomander,多重启几次,还是不行就换换别人的 efi 试试。我反正就是这么 ...

好的 非常感谢

Rank: 2Rank: 2

UID
2728712
帖子
252
PB币
5
贡献
0
技术
0
活跃
430
发表于 2019-2-25 19:58:17 |显示全部楼层
zjt3000 发表于 2019-2-25 19:54
我建议:更新各个驱动,加入 codecomander,多重启几次,还是不行就换换别人的 efi 试试。我反正就是这么 ...

你还需要按照黑果小兵的方法驱动显卡,开启 hidpi,注意如果是10.14.x 的话还要把显卡的 注入 id 从1659改成1619什么的,我的触摸板是 i2c,用的 voodooi2c,其他的小修改,你看看吧,我也稀里糊涂,总之谢谢你的 efi。

Rank: 2Rank: 2

UID
2853684
帖子
445
PB币
269
贡献
0
技术
0
活跃
438
发表于 2019-3-1 07:32:20 |显示全部楼层
魂牵梦Mong 发表于 2019-2-25 19:13
现在我也是注入id 3  耳机还是有背景音,可能是驱动文件不能用吧
能分享一下你的efi吗?

efi地址:https://github.com/ysx25261465/Acer-TravelMate-TX40-G2

Rank: 1

UID
4842229
帖子
14
PB币
0
贡献
0
技术
0
活跃
38
发表于 2019-3-3 12:01:30 |显示全部楼层
试试看看了

Rank: 2Rank: 2

UID
2181613
帖子
222
PB币
1000
贡献
0
技术
1
活跃
141
发表于 2019-3-6 09:22:26 |显示全部楼层
ysx25261465 发表于 2019-2-25 19:01
我的github地址:https://github.com/ysx25261465/Acer-TravelMate-TX40-G2

有时间可以研究下

你好,同款机器,直接套用了你的EFI,无法正常关机和重启,点关机或重启后屏幕就黑了但是指示灯还是亮的,没有关机或重启,请教一下这是什么原因呢

Rank: 2Rank: 2

UID
2853684
帖子
445
PB币
269
贡献
0
技术
0
活跃
438
发表于 2019-3-6 09:31:02 |显示全部楼层
lich1021 发表于 2019-3-6 09:22
你好,同款机器,直接套用了你的EFI,无法正常关机和重启,点关机或重启后屏幕就黑了但是指示灯还是亮的, ...

修复缓存了吗

Rank: 2Rank: 2

UID
2181613
帖子
222
PB币
1000
贡献
0
技术
1
活跃
141
发表于 2019-3-6 09:36:44 |显示全部楼层
ysx25261465 发表于 2019-3-6 09:31
修复缓存了吗

我是直接拖到clover中覆盖的,没有进行其他操作,是我漏了什么步骤吗
回顶部
Copyright (C) 2005-2020 pcbeta.com, All rights reserved
Powered by Discuz!  苏ICP备17027154号
请勿发布违反中华人民共和国法律法规的言论,会员观点不代表远景论坛官方立场。
远景在线 | 远景论坛 | 苹果论坛 | Win10论坛 | Win8论坛 | Win7论坛 | WP论坛 | Office论坛 | 电脑硬件 | 安卓软件