Win10论坛

Win10正式版系统下载主题平板

重定义Modern UI,打造完美Windows全新体验

Windows10下载|安装|新手宝典|必备软件

搜索
查看: 17334|回复: 271

[独显] 尝试了很多,rx580终于算是完美了吧,8700K,技嘉Z370,目前一切正常   [复制链接]

Rank: 2Rank: 2

UID
4754552
帖子
243
PB币
181
贡献
0
技术
0
活跃
191
发表于 2019-3-10 07:43:37 |显示全部楼层
本帖最后由 sevenbo 于 2019-4-3 23:31 编辑

4月3日更新:10.14.5-一切正常。关于本机-图形卡面板核显信息没有了。
其他一切稳定。再次感谢坛友的支持,希望能帮到更多的坛友!加油哈!
3.11日更新-应网友要求把efi上传
首先黑苹果是不可能有完美的
个人感觉除去我装了黑苹果的笔记本,那家伙超级完美,从[size=1em]OS X Yosemite一路无痛升级到14.4。所有功能完美。
分割线
------------------------------------------------
现在说说台式机
配置是技嘉Z370,8700k,极光580-8G
------------------------------------------------
因为我需要剪片子,fcpx,pr,ae,me,dvr等等影视类软件吧
所以对显卡要求稍微高点,不是能用就行,最好是趋近于完美。
------------------------------------------------
装好后一直面临,h.264编码问题
从fcpx无法共享,到共享成功独显利用率低,到独显核显都利用起来但是共享画面绿条撕裂马赛克,pr也是一样。
尝试过比如打开核显和关闭核显,放入
http://bbs.pcbeta.com/viewthread-1805350-1-1.htmldummy144.kext,还有修改机型,使用别人的dsdt(我不会改)
各种方法都试了,我不是大神,只会下载别人弄好的配置文件,人后对比修改一下适合自己的,
-----------------------------------------------
最后,找到了根本原因
1、只需要在clover里的Devices下的FakeID添加IntelGFX为0x3e928086
  然后在Graphics下添加ig-platform-id为0x3e920003

2、或者直接在Devices里添加Properties(两种方法二选一)(3月11日:这个是Hackintool的补丁。自行充电。很简单)

然而核显的完美利用与否只是取决于用了8代cpu自己的设备id
7代的0x59128086不行。会导致各种问题。

不设置的话一般会自动识别为8代的吧(不懂,估计是)
---------------------------------------------------------------
区别就是
第一种会显示,两个显卡信息


而第二种只会显示独显
两种方法效果是一样的。(估计吧,不确定)
第一种方法比较适合有强迫症的(比如我)
喜欢吧所有设备都显示出来

类似这样
----------------------------------------------------------------
目前。核显是一直利用起来的。包括空格,和看网页视频,腾讯优酷等等

独显的话,在渲染输出编码的时候是满速的,需要用的时候两者都会出现。

videoproc也显示正常

-----------------------------------------------------------------
所有软件一切正常,没有闪退,冻屏,关机,绿条,马赛克,撕裂等等问题。
----------------------------------------------------------------
黑苹果在于折腾,比较费发际线
没有完美的黑苹果,只能说趋向于完美。更加的稳定。用到的功能可以用起来。而不是摆那儿看着用不到,
在继续加油吧!
就说这么多吧。
-----------------------------------------------------------------
应坛友需求附efi文件







附件: 你需要登录才可以下载或查看附件。没有帐号?注册

Rank: 2Rank: 2

UID
4754552
帖子
243
PB币
181
贡献
0
技术
0
活跃
191
发表于 2019-3-10 08:48:35 |显示全部楼层
补充一下8700k的设备id就是0x3e92
而0x5912是7代显卡的id。

111

Rank: 2Rank: 2

UID
2485616
帖子
187
PB币
295
贡献
0
技术
0
活跃
491
发表于 2019-3-10 09:03:20 来自手机 |显示全部楼层
感谢楼主测试 回来试试

Rank: 2Rank: 2

UID
4607922
帖子
70
PB币
0
贡献
0
技术
0
活跃
103
发表于 2019-3-10 09:15:24 来自手机 |显示全部楼层
我和你一样能看见两个显卡设备,但是不知道有没有驱动,笔记本双显卡

Rank: 1

UID
4115357
帖子
39
PB币
22
贡献
0
技术
0
活跃
92
发表于 2019-3-10 09:16:14 来自手机 |显示全部楼层
渲染的时候显卡有时工作有时不工作  怎么回事

Rank: 2Rank: 2

UID
4754552
帖子
243
PB币
181
贡献
0
技术
0
活跃
191
发表于 2019-3-10 09:49:44 |显示全部楼层
fqj1 发表于 2019-3-10 09:16
渲染的时候显卡有时工作有时不工作  怎么回事

264或者265的话没问题的吧,其他格式就不一定了

Rank: 2Rank: 2

UID
4792419
帖子
158
PB币
106
贡献
0
技术
0
活跃
244
发表于 2019-3-10 10:04:22 |显示全部楼层
楼主  有efi吗

Rank: 7Rank: 7Rank: 7

UID
167086
帖子
1591
PB币
1527
贡献
0
技术
19
活跃
1235
发表于 2019-3-10 11:00:39 |显示全部楼层
楼主的PCI列表是咋弄的,请一并赐教。

Rank: 2Rank: 2

UID
4754552
帖子
243
PB币
181
贡献
0
技术
0
活跃
191
发表于 2019-3-10 11:11:48 |显示全部楼层
胡仁乐 发表于 2019-3-10 09:15
我和你一样能看见两个显卡设备,但是不知道有没有驱动,笔记本双显卡

不太清楚,我这儿只是弄得列表里显示出来了而已,我测试过,笔记本不清楚,台式机如果要想好好利用核显的话,核显下边信息里边的Metal项不能有【支持,功能集 macOS GPUFamily2 v1】如果有显示这个东西的话,台式机用核显的时候回各种问题。

Rank: 5Rank: 5Rank: 5

UID
2264016
帖子
738
PB币
245
贡献
0
技术
64
活跃
1383
发表于 2019-3-10 11:20:44 |显示全部楼层
感谢楼主分享

Rank: 2Rank: 2

UID
1710298
帖子
299
PB币
23
贡献
0
技术
0
活跃
544
发表于 2019-3-10 11:44:58 |显示全部楼层
我的RX590 videoproc下一刷新HEVC就死机卡住,郁闷。

Rank: 2Rank: 2

UID
1710298
帖子
299
PB币
23
贡献
0
技术
0
活跃
544
发表于 2019-3-10 11:47:47 |显示全部楼层
ydhmq 发表于 2019-3-10 11:00
楼主的PCI列表是咋弄的,请一并赐教。

我的也没,图标卡上的插槽也不显示。

Rank: 2Rank: 2

UID
4754552
帖子
243
PB币
181
贡献
0
技术
0
活跃
191
发表于 2019-3-10 11:49:57 |显示全部楼层
Hackxzy 发表于 2019-3-10 11:44
我的RX590 videoproc下一刷新HEVC就死机卡住,郁闷。

590估计支持不太好,是软件的问题吧,你fcpx这些软件输出编码没问题就行了

Rank: 2Rank: 2

UID
4754552
帖子
243
PB币
181
贡献
0
技术
0
活跃
191
发表于 2019-3-10 12:01:44 |显示全部楼层
ydhmq 发表于 2019-3-10 11:00
楼主的PCI列表是咋弄的,请一并赐教。

这个需要用dsdt

Rank: 2Rank: 2

UID
4835068
帖子
274
PB币
208
贡献
0
技术
0
活跃
264
发表于 2019-3-10 12:54:18 |显示全部楼层
本帖最后由 lowed 于 2019-3-10 12:57 编辑

我是蓝宝石RX580 8g 也是两个信息都有出来。但是不知道渲染速度到底是正不正常,有没有加速。那个5k渲染输出13-15秒左右。那个2秒的5k测试视频

Rank: 5Rank: 5Rank: 5

UID
3087159
帖子
733
PB币
1336
贡献
0
技术
0
活跃
1007
发表于 2019-3-10 13:10:45 |显示全部楼层
本帖最后由 jzhjm 于 2019-3-10 13:14 编辑

我有一台配置好像和你一样CPU:Intel i7-8700K
GPU:蓝宝石 AMD RX580 8G 超白金极光
主板:技嘉 Z370M-H3DP

Rank: 7Rank: 7Rank: 7

UID
876573
帖子
2028
PB币
1631
贡献
0
技术
0
活跃
1381
发表于 2019-3-10 13:49:49 |显示全部楼层
sevenbo 发表于 2019-3-10 12:01
这个需要用dsdt

兄弟的是技嘉什么主板?求分享个你pci dsdt的教程

Rank: 2Rank: 2

UID
4754552
帖子
243
PB币
181
贡献
0
技术
0
活跃
191
发表于 2019-3-10 14:15:48 |显示全部楼层
415793633 发表于 2019-3-10 13:49
兄弟的是技嘉什么主板?求分享个你pci dsdt的教程

z370 hd3.用的别人的,反正能显示,凑合事了

Rank: 2Rank: 2

UID
4754552
帖子
243
PB币
181
贡献
0
技术
0
活跃
191
发表于 2019-3-10 14:17:09 |显示全部楼层
lowed 发表于 2019-3-10 12:54
我是蓝宝石RX580 8g 也是两个信息都有出来。但是不知道渲染速度到底是正不正常,有没有加速。那个5k渲染输出 ...

用iStat Menus查看

Rank: 2Rank: 2

UID
4403674
帖子
222
PB币
0
贡献
0
技术
0
活跃
250
发表于 2019-3-10 14:23:14 |显示全部楼层
楼主用了你的办法后 还是只有独显加速 核显一动不动啊
回顶部
Copyright (C) 2005-2019 pcbeta.com, All rights reserved
Powered by Discuz!  苏ICP备17027154号
请勿发布违反中华人民共和国法律法规的言论,会员观点不代表远景论坛官方立场。
远景在线 | 远景论坛 | 苹果论坛 | Win10论坛 | Win8论坛 | Win7论坛 | WP论坛 | Office论坛 | 电脑硬件 | 安卓软件