Win10论坛

Win10正式版系统下载主题平板

重定义Modern UI,打造完美Windows全新体验

Windows10下载|安装|新手宝典|必备软件

搜索
查看: 709|回复: 14

[核显] 移动版的HD4600驱动咋就那么难,都一个月还是显存7M [复制链接]

Rank: 2Rank: 2

UID
1954884
帖子
348
PB币
3
贡献
0
技术
21
活跃
290
发表于 2019-3-20 00:10:47 |显示全部楼层
神舟K650D i7 D3
CPU:i7 4710MQ
独显:GTX950M (算是屏蔽了)

折腾这个核显HD4600都快一个月了,结果试各种办法还是显存7M

用坛里同型号类型号的EFI,基本都是卡IGPU,删掉对方的ACPI就可以进系统,但是显存还是7M

试过hotpathed,试过黑果小兵的hackintool,试过自改DSDT+SSDT,还是只是识别显卡HD4600,显存7M

搞了太久,时间耗挺多的,就找了马云家黑果弄下核显,搞了大半天也说搞不了

这个笔记本是带有VGA和HDMI接口的,外接投影仪都可以使用,只是显存更小,变为3M

不知道有没有大神知道怎么解决这问题,核显驱动能识别,驱动没法加载

[img]blob:http://bbs.pcbeta.com/4d9b540a-8bd8-49b0-83a6-fda4543fc691[/img]

[img]blob:http://bbs.pcbeta.com/de07ab73-8dc8-4f2d-91aa-490f8c732b3a[/img]

[img]blob:http://bbs.pcbeta.com/e1e128d9-1599-43bf-b9ff-d436ed9fe456[/img]



附上我的ACPI,kext,config,IORegistry




附件: 你需要登录才可以下载或查看附件。没有帐号?注册

Rank: 7Rank: 7Rank: 7

UID
4842671
帖子
2520
PB币
3184
贡献
0
技术
10
活跃
637
发表于 2019-3-20 08:29:27 |显示全部楼层
https://github.com/RehabMan/OS-X-Clover-Laptop-Config/blob/master/config_HD4600_4400_4200.plist

Rank: 2Rank: 2

UID
1954884
帖子
348
PB币
3
贡献
0
技术
21
活跃
290
发表于 2019-3-20 13:28:31 |显示全部楼层
云朵有点甜 发表于 2019-3-20 08:29
https://github.com/RehabMan/OS-X-Clover-Laptop-Config/blob/master/config_HD4600_4400_4200.plist

这个没用,卡IGPU,进不去系统

Rank: 2Rank: 2

UID
4758859
帖子
67
PB币
52
贡献
0
技术
0
活跃
69
发表于 2019-3-26 21:02:16 |显示全部楼层
我和你一样,我驱动了4600,怎么给你EFi

Rank: 1

UID
4851686
帖子
15
PB币
8
贡献
0
技术
0
活跃
42
发表于 2019-4-29 19:58:24 |显示全部楼层
现在的镜像一般都会带有一些显卡的驱动的config,例如config_4200_4600.plist这样的文件,中间的数值就是显卡的型号,你看一下你的核显型号,然后找到对应的把中间的数值去掉替换原来的config.plist就行,不过这样开机会出现花屏的情况,需要将四叶草的分辨率改为1024×768

Rank: 2Rank: 2

UID
4851914
帖子
40
PB币
18
贡献
0
技术
0
活跃
44
发表于 2019-4-29 22:04:38 |显示全部楼层
对,我之前也是永远的7m,直到遇到同型号的大佬才解决的

Rank: 2Rank: 2

UID
4852080
帖子
64
PB币
138
贡献
0
技术
0
活跃
53
发表于 2019-4-30 09:26:42 |显示全部楼层
我的是i5-4210u  显卡HD4400,开始安装的是14.4 显卡驱动总是有问题,换了好多都不行,后来换成13.6的系统,一切都OK了

Rank: 2Rank: 2

UID
1954884
帖子
348
PB币
3
贡献
0
技术
21
活跃
290
发表于 2019-5-3 19:53:03 |显示全部楼层
Johnnyno9 发表于 2019-4-29 22:04
对,我之前也是永远的7m,直到遇到同型号的大佬才解决的

我换同一型号的其他比较完美的EFI 也不行

Rank: 2Rank: 2

UID
1954884
帖子
348
PB币
3
贡献
0
技术
21
活跃
290
发表于 2019-5-3 19:54:02 |显示全部楼层
dongtian888 发表于 2019-4-30 09:26
我的是i5-4210u  显卡HD4400,开始安装的是14.4 显卡驱动总是有问题,换了好多都不行,后来换成13.6的系统, ...

我也试过好几个低版本系统,也是有问题

Rank: 2Rank: 2

UID
4851914
帖子
40
PB币
18
贡献
0
技术
0
活跃
44
发表于 2019-5-4 12:04:41 |显示全部楼层
he271481179 发表于 2019-5-3 19:53
我换同一型号的其他比较完美的EFI 也不行

安装系统版本也必须要一致

Rank: 7Rank: 7Rank: 7

UID
4842671
帖子
2520
PB币
3184
贡献
0
技术
10
活跃
637
发表于 2019-5-4 12:14:23 来自手机 |显示全部楼层
he271481179 发表于 2019-3-20 13:28
这个没用,卡IGPU,进不去系统

你引导没配好

Rank: 1

UID
4823336
帖子
13
PB币
37
贡献
0
技术
0
活跃
26
发表于 2019-7-23 11:44:39 |显示全部楼层
村长ABC 发表于 2019-4-29 19:58
现在的镜像一般都会带有一些显卡的驱动的config,例如config_4200_4600.plist这样的文件,中间的数值就是显 ...

您好,我也是这个问题,请问怎么修改四叶草分辨率呢

Rank: 1

UID
4856373
帖子
31
PB币
26
贡献
0
技术
0
活跃
21
发表于 2019-7-29 10:24:05 |显示全部楼层
我的也是,整了很久,各种方法没搞定,换成10.12.6好了

Rank: 1

UID
4668841
帖子
25
PB币
6
贡献
0
技术
0
活跃
49
发表于 2019-8-14 16:15:38 |显示全部楼层
楼主后来搞定了吗?我也是驱不动 HD4600,什么方法都试过了,没辙了

Rank: 2Rank: 2

UID
1954884
帖子
348
PB币
3
贡献
0
技术
21
活跃
290
发表于 2019-10-28 13:31:53 |显示全部楼层
pinocchio2mx 发表于 2019-8-14 16:15
楼主后来搞定了吗?我也是驱不动 HD4600,什么方法都试过了,没辙了

搞不定 放弃
回顶部
Copyright (C) 2005-2019 pcbeta.com, All rights reserved
Powered by Discuz!  苏ICP备17027154号
请勿发布违反中华人民共和国法律法规的言论,会员观点不代表远景论坛官方立场。
远景在线 | 远景论坛 | 苹果论坛 | Win10论坛 | Win8论坛 | Win7论坛 | WP论坛 | Office论坛 | 电脑硬件 | 安卓软件