Win10论坛

Win10正式版系统下载主题平板

重定义Modern UI,打造完美Windows全新体验

Windows10下载|安装|新手宝典|必备软件

搜索
查看: 23444|回复: 181

[独显] 重点完美更新!完美黑苹果=Z370M+i5+RX590(硬解)10.15   [复制链接]

Rank: 2Rank: 2

UID
1990592
帖子
116
PB币
57
贡献
0
技术
2
活跃
315
发表于 2019-6-26 20:16:37 |显示全部楼层
本帖最后由 cbw390179428 于 2019-8-17 16:30 编辑

先来张图给大家解解馋!



配置是


主板:微星Z370M

CPU:i5-8600K

显卡:女装大佬RX590

内存:芝棋8G-3000

显示器:戴尔U2417H


经过半年的调整现在完美黑苹果。换了RX590,琢磨了很长时间的硬件解码,最后成功硬解。关于这个问题,后面我会详细解释一下。EFI文件后面再追加。


关于硬件解码

这几天研究了很久硬件解码,主要是5代以后的CPU带核显的情况,关于不带核显的情况我也不知道,朋友从别的地方了解一下吧。本文想讲述一下带核显的情况开启硬件加速。

先说结论:other里面放入whatevergreen,lilu,AGPM三个插件,后面这个AGPM可以下一个生成器(名字叫AGPMinjector,用来生成对应SMBIOS系统相应的核显驱动)。在图形卡显示器里面会有两个显卡(HD核显和毒显)。我两个显示器都连接在了毒显上面。


我搜索了很多资料。大概意思是核显不显示输出只是参与解码的过程,帮助渲染但不视频输出,如果要接显示器也可以,但会有chrome或者部分软件花屏的现象。


config里面将INTELGFX的ID写上,还有显卡部分填入inject intel和ig-platform-id 两个数据。我没有装FXCP之类的软件,但是有两三个高码率的4K影片(高码率基本在80M/s这样的数据,为的是增加核显解码的压力,不然判定不出来到底是不是硬解,或者是CPU参与的解码)。


按照我这样的配置,显卡部分两个都能看的到,解码过程中影片流畅播放,而且在任务管理器部分可以看到毒显全速运行,核显半速运行,而CPU压力很低。能稳定播放说明硬解成功。


VideoProc这个软件硬件解码部分上写的是UHD630,双硬解。


好不容易发帖一次,审核半天我以为过不去了……心就碎了

我看网上很多人在讨论关于硬件解码这个问题。所以我也研究了一下。成不成功,就看播放高码率4K视频观察任务管理器的显示情况。

有很多伪硬件加速的结果就是,显卡部分只有一个显卡(毒显),这样一来,核显不参与输出视频,部分应用硬件加速会花屏,这样肯定是不完美的。比如chrome,开启硬件解码正常不花瓶。


更新7.3:问题1:关于IINA播放器播放视频会没有全速运用硬件加速的问题,我也观察过搜集过,是播放器的问题,推荐用本级自带的QuickPlayer或者VLC一起观察硬件解码。
问题2:更新显卡部分截图




EFI我在文章更新一下,具体的信息也可以到我的github里面看:michaelvector.github.io

重点更新!!!!



其实很长一段时间没有更新的原因是有些问题我并不是十分确定也一直在研究,虽然确实可以实现硬解,但驱动还是算是参数式伪驱动,虽然没什么问题,但我也有强迫症啊,在参考了相关资料和黑鬼小兵大神的相关帖子后打算重做配置。这次的10.15就是再此基础上重新配置。




原理:从方法方式上进行更新,相应驱动也会配合本机更加完美。CPU原生支持,声卡、NVMe、USB、HDMI音频和显卡都是从主板PCI设备接口自动识别而来,并不是添加仿冒参数。因此设备设置里的IntelGFX和显卡设置里都无需添加任何相关仿冒参数(3E9B007),从而UHD630和RX590都是原生PCI生成的参数。







里面的GPU0和GPU1都是自动生成的,而且我连接双显示器。独显1080P,UHD核显连接的副显示器(1440*900),双显示器完美运行,硬件加速及4K都完美运行。




而且!!省电啊!!!


因为副显示器连接的是核显,因此在核显上播放视频或者直播用的是相应的核显来处理。


第一解决了独显负载高的问题(省电和优化资源分配)


第二是独显上只有一个输出接口连接的主显示器,独显的内存频率可以大道最低400MHz。这个问题是独显连接两个及以上的显示器会造成内存频率稳定最高(2000MHz)而且不可以动态调节内存频率=耗电。(省电和不必要的能源浪费)




总结:这次的更新硬解相关只是一个思路为大家完美黑苹果提供的帖子,还是感谢一直在黑苹果一线摸索攀爬的大神,黑果小兵大神的帖子帮助了我很多,在此感谢。


这次的配置更新应该算我比较肯定一些的配置方法,确定的黑苹果应该就如此配置。不过要是有不一样意见的也希望大家多多指点,共同进步嘛!


附件: 你需要登录才可以下载或查看附件。没有帐号?注册

Rank: 1

UID
4644323
帖子
29
PB币
0
贡献
0
技术
0
活跃
67
发表于 2019-6-26 20:24:25 |显示全部楼层
厉害了,我这i7-9700k,z390、rx590还没硬解上

Rank: 1

UID
3800646
帖子
24
PB币
24
贡献
0
技术
0
活跃
87
发表于 2019-6-26 20:26:30 |显示全部楼层
mark一下 看楼主的更新

Rank: 1

UID
1676255
帖子
56
PB币
98
贡献
0
技术
0
活跃
223
发表于 2019-7-1 11:12:22 |显示全部楼层
楼主求分享EFI或者plist

Rank: 1

UID
3917607
帖子
43
PB币
66
贡献
0
技术
0
活跃
84
发表于 2019-7-1 20:03:58 来自手机 |显示全部楼层
smbios选的是什么?我现在是imacpro1.1,显卡能够硬解,可是RX580显示确是RX570,而且核显不显示,很尴尬!

Rank: 2Rank: 2

UID
4684214
帖子
191
PB币
55
贡献
0
技术
0
活跃
171
发表于 2019-7-1 20:37:35 |显示全部楼层

smbios选的是什么?我现在是imacpro1.1,显卡能够硬解,可是RX580显示确是RX570,而且核显不显示,很尴尬!

Rank: 2Rank: 2

UID
1610668
帖子
142
PB币
4284
贡献
0
技术
0
活跃
641
发表于 2019-7-1 22:44:46 |显示全部楼层
请问哈你的黑苹果10.14.5开机黑苹果在进度条哪儿出现卡顿一下花屏后再进入系统吗?

Rank: 2Rank: 2

UID
1990592
帖子
116
PB币
57
贡献
0
技术
2
活跃
315
发表于 2019-7-2 00:54:45 |显示全部楼层
ljpengjian 发表于 2019-7-1 22:44
请问哈你的黑苹果10.14.5开机黑苹果在进度条哪儿出现卡顿一下花屏后再进入系统吗?

分两个阶段,第一阶段正常读条,到3/4处卡一下,屏幕上面有紫色的横线,卡顿一下正常进入系统

Rank: 2Rank: 2

UID
1990592
帖子
116
PB币
57
贡献
0
技术
2
活跃
315
发表于 2019-7-2 00:55:01 |显示全部楼层
lzf224 发表于 2019-7-1 11:12
楼主求分享EFI或者plist

ok明天了上传

Rank: 2Rank: 2

UID
1990592
帖子
116
PB币
57
贡献
0
技术
2
活跃
315
发表于 2019-7-2 00:56:10 |显示全部楼层
asd824589577 发表于 2019-7-1 20:37
smbios选的是什么?我现在是imacpro1.1,显卡能够硬解,可是RX580显示确是RX570,而且核显不显示,很尴尬 ...

我的是19.1,是你的显卡参数没设置对,把AMD显卡初始化那个选项关闭应该可以

Rank: 1

UID
4850295
帖子
37
PB币
7
贡献
0
技术
0
活跃
106
发表于 2019-7-2 11:30:19 |显示全部楼层
额 那配置文件呢?不过我是390 9700K话说通用么?

Rank: 1

UID
2409727
帖子
64
PB币
99
贡献
0
技术
0
活跃
112
发表于 2019-7-2 13:01:13 |显示全部楼层
你好,我想问一下你的机型是19.1     inject intel     ig-platform-id   INTELGFX这三个填了什么?

Rank: 2Rank: 2

UID
4716480
帖子
127
PB币
118
贡献
0
技术
0
活跃
241
发表于 2019-7-2 15:23:02 |显示全部楼层
大佬能分享下你的config设置吗?还有efi

Rank: 1

UID
3866616
帖子
20
PB币
1
贡献
0
技术
0
活跃
28
发表于 2019-7-2 16:34:00 |显示全部楼层
留印,下次安装时再看

Rank: 2Rank: 2

UID
1206255
帖子
112
PB币
352
贡献
0
技术
2
活跃
588

7周年庆典勋章

发表于 2019-7-2 18:51:36 |显示全部楼层
求LZ EFI进行研究,觉得LZ说得很对,viedeoproc显示双硬解和UHD630,但是istate没有显示核显,核显die也没有,最诡异是每次开机都要恢复BIOS,然后重新打开多显示才能进系统。系统里面也只有RX570没有核显,一直觉得是伪硬件加速

Rank: 1

UID
4809661
帖子
62
PB币
0
贡献
0
技术
0
活跃
103
发表于 2019-7-2 20:46:52 |显示全部楼层
积分不够。评论来凑

Rank: 5Rank: 5Rank: 5

UID
842292
帖子
1082
PB币
632
贡献
0
技术
5
活跃
945
发表于 2019-7-2 21:49:01 来自手机 |显示全部楼层
我还是建议关掉核显,直接用独显,在10.14.5版本,已经很完美了各种功能,用核显有时播放器会出和

Rank: 1

UID
3917607
帖子
43
PB币
66
贡献
0
技术
0
活跃
84
发表于 2019-7-2 21:51:14 |显示全部楼层
cbw390179428 发表于 2019-7-2 00:54
分两个阶段,第一阶段正常读条,到3/4处卡一下,屏幕上面有紫色的横线,卡顿一下正常进入系统



依旧还是这个样子!不知道问题出在哪里!对比一下,帮忙看看问题出在哪里


附件: 你需要登录才可以下载或查看附件。没有帐号?注册

Rank: 5Rank: 5Rank: 5

UID
842292
帖子
1082
PB币
632
贡献
0
技术
5
活跃
945
发表于 2019-7-2 22:17:20 来自手机 |显示全部楼层
我还是建议关掉核显,直接用独显,在10.14.5版本,已经很完美了各种功能,用核显有时播放器出错机会大,特别是iina硬解变软解

Rank: 2Rank: 2

UID
2720144
帖子
136
PB币
18
贡献
0
技术
0
活跃
296

7周年庆典勋章

发表于 2019-7-3 08:31:10 |显示全部楼层
cbw390179428 发表于 2019-7-2 00:54
分两个阶段,第一阶段正常读条,到3/4处卡一下,屏幕上面有紫色的横线,卡顿一下正常进入系统

rx580的同样的问题
回顶部
Copyright (C) 2005-2020 pcbeta.com, All rights reserved
Powered by Discuz!  苏ICP备17027154号
请勿发布违反中华人民共和国法律法规的言论,会员观点不代表远景论坛官方立场。
远景在线 | 远景论坛 | 苹果论坛 | Win10论坛 | Win8论坛 | Win7论坛 | WP论坛 | Office论坛 | 电脑硬件 | 安卓软件