Win10论坛

Win10正式版系统下载主题平板

重定义Modern UI,打造完美Windows全新体验

Windows10下载|安装|新手宝典|必备软件

搜索
查看: 1792|回复: 5

[讨论] 大家是怎么解决gedit下中文乱码的问题的? [复制链接]

Rank: 7Rank: 7Rank: 7

UID
1663598
帖子
432
PB币
1028
贡献
0
技术
10
活跃
29

7周年庆典勋章

发表于 2012-6-7 11:09:04 |显示全部楼层
我用的是ubuntu12.04LTS 用U盘引导安装,参照论坛立的帖子装的。装上后一切正常就是中文支持不给力,所以想问问大家都是怎么解决乱码问题的。主要是针对 gedit一类的文本编辑器。
我用的是终端运行  dconf-editor,然后在里面修改org -gnome-gedit-preferences-encording  然后在右面的两个选项里面加入中文编码,GB18030 GB2312 这样之后基本可以保证大部分TXT中文无乱码,但是也有个别文件。。。所以对剩下的文件我用的是office 打开。。。。。打开的时候选择中文编码就可以了  
大家都用的是什么方法呢?

苦逼准程序员

Rank: 7Rank: 7Rank: 7

UID
1948921
帖子
267
PB币
586
贡献
0
技术
0
活跃
105
发表于 2012-6-8 12:40:27 |显示全部楼层
按下 Alt-F2,打开“运行应用程序”对话框。
在文本框中键入“gconf-editor”,并按下回车键,打开“配置编辑器”。
展开左边的树节点,找到 /apps/gedit-2/preferences/encodings 节点并单击它。
双击右边的 auto_detected 键,打开“编辑键”对话框。
单击列表右边的“添加”按钮,输入“GB18030”,单击确定按钮。
列表的最底部新增加了一个“GB18030”。单击选中它,并单击右边的 “向上” 按钮直到 “GB18030” 位于列表的顶部为止。
单击确定按钮,关闭配置编辑器。

Rank: 7Rank: 7Rank: 7

UID
1663598
帖子
432
PB币
1028
贡献
0
技术
10
活跃
29

7周年庆典勋章

发表于 2012-6-8 12:43:07 |显示全部楼层
qinyao0312 发表于 2012-6-8 12:40
按下 Alt-F2,打开“运行应用程序”对话框。
在文本框中键入“gconf-editor”,并按下回车键,打开“配置编 ...

额,如果我没有看错的话,我就是已经按你说的设置过了。。解决了大部分的乱码问题,不过仍然有少数TXT中文乱码。。。。

Rank: 2Rank: 2

UID
2477084
帖子
88
PB币
102
贡献
0
技术
0
活跃
14

7周年庆典勋章

发表于 2012-6-8 13:11:37 |显示全部楼层
终端
gsettings set org.gnome.gedit.preferences.encodings auto-detected "['UTF-8','GB18030','GB2312','GBK','BIG5','CURRENT','UTF-16']"

Rank: 1

UID
1079458
帖子
71
PB币
120
贡献
0
技术
0
活跃
22
发表于 2012-6-10 19:25:32 |显示全部楼层
安装UBUNTU TWEAK 在调整-迂回修正 里面 有设置

Rank: 7Rank: 7Rank: 7

UID
1663598
帖子
432
PB币
1028
贡献
0
技术
10
活跃
29

7周年庆典勋章

发表于 2012-6-10 20:10:26 |显示全部楼层
MPFOR 发表于 2012-6-10 19:25
安装UBUNTU TWEAK 在调整-迂回修正 里面 有设置

恩 暂时还没有安装tweak  有时间试试吧,用gedit不太多,要考试了。。
回顶部
Copyright (C) 2005-2020 pcbeta.com, All rights reserved
Powered by Discuz!  苏ICP备17027154号
请勿发布违反中华人民共和国法律法规的言论,会员观点不代表远景论坛官方立场。
远景在线 | 远景论坛 | 苹果论坛 | Win10论坛 | Win8论坛 | Win7论坛 | WP论坛 | Office论坛 | 电脑硬件 | 安卓软件