Win10论坛

Win10正式版系统下载主题平板

重定义Modern UI,打造完美Windows全新体验

Windows10下载|安装|新手宝典|必备软件

搜索
查看: 7876|回复: 23

[交流] Dell 3421笔记本基本成功体验Yosemite,Clover驱动HD4000 [复制链接]

Rank: 7Rank: 7Rank: 7

UID
501120
帖子
2590
PB币
4678
贡献
0
技术
234
活跃
1164
发表于 2014-7-8 02:41:32 |显示全部楼层
本帖最后由 hasimu 于 2014-7-8 13:41 编辑

经过几个小时的努力Dell 3421笔记本用clover引导成功安装Yosemite DP1.驱动除了无线网卡无解其他都搞定了,最让我头疼的是HD4000的ig-platform-id问题,从0到9再a和b都试过了,不是黑屏就是花屏,什么都没有。最后ig-platform-id用0x01660003再加个PCI的DeviceProperties值来成功驱动了hd4000.
config代码如下:
  1.         <key>Graphics</key>
  2.         <dict>
  3.                 <key>Inject</key>
  4.                 <dict>
  5.                         <key>ATI</key>
  6.                         <false/>
  7.                         <key>Intel</key>
  8.                         <true/>
  9.                         <key>NVidia</key>
  10.                         <false/>
  11.                 </dict>
  12.                 <key>ig-platform-id</key>
  13.                 <string>0x01660003</string>
  14.         </dict>
  15.         <key>PCI</key>
  16.         <dict>
  17.                 <key>DeviceProperties</key>
  18.                 <string>5e0000000100000001000000520000000100000002010c00d041030a000000000101060000027fff04002c0000004100410050004c002c00690067002d0070006c006100740066006f0072006d002d006900640000000800000003006601</string>
  19.                 <key>StringInjector</key>
  20.                 <true/>
  21.         </dict>
复制代码
其他声卡,有线网卡,电池图标等都正常。

上图:
1.jpg

2.jpg

3.jpg

4.jpg

5.jpg

6.jpg

7.jpg


新系统的确不错,期待正式版早日到来!
2

查看全部评分

Rank: 7Rank: 7Rank: 7

UID
501120
帖子
2590
PB币
4678
贡献
0
技术
234
活跃
1164
发表于 2014-7-8 02:57:23 |显示全部楼层
亮度自动调节也正常

Rank: 7Rank: 7Rank: 7

UID
678781
帖子
1478
PB币
0
贡献
0
技术
14
活跃
1076

活动参与先锋 8周年庆典勋章

发表于 2014-7-8 07:15:59 |显示全部楼层
hasimu 发表于 2014-7-8 02:57
亮度自动调节也正常

能不能分享一下你dsdt

Rank: 2Rank: 2

UID
3335393
帖子
66
PB币
0
贡献
0
技术
0
活跃
416
发表于 2014-7-8 08:10:32 |显示全部楼层
似乎10.10的核显都比较难搞 不知道我的hd4600能否驱动

Rank: 2Rank: 2

UID
3580358
帖子
139
PB币
150
贡献
0
技术
47
活跃
122
发表于 2014-7-8 13:35:09 |显示全部楼层
开机你的会花屏后猜正常进入登录界面不

Rank: 7Rank: 7Rank: 7

UID
501120
帖子
2590
PB币
4678
贡献
0
技术
234
活跃
1164
发表于 2014-7-8 13:37:27 |显示全部楼层
zhanglei138099 发表于 2014-7-8 07:15
能不能分享一下你dsdt

我没用 dsdt,直接clover驱动的

Rank: 7Rank: 7Rank: 7

UID
501120
帖子
2590
PB币
4678
贡献
0
技术
234
活跃
1164
发表于 2014-7-8 13:38:40 |显示全部楼层
xiaobu888 发表于 2014-7-8 13:35
开机你的会花屏后猜正常进入登录界面不

是的,准备进桌面的时候有1-2秒短暂的花屏后才出现桌面,其他时候正常!

Rank: 2Rank: 2

UID
3580358
帖子
139
PB币
150
贡献
0
技术
47
活跃
122
发表于 2014-7-8 13:39:21 |显示全部楼层
hasimu 发表于 2014-7-8 13:38
是的,准备进桌面的时候有1-2秒短暂的花屏后才出现桌面,其他时候正常!

看来hd4000这个问题目前全球无解啊

Rank: 7Rank: 7Rank: 7

UID
501120
帖子
2590
PB币
4678
贡献
0
技术
234
活跃
1164
发表于 2014-7-8 13:42:47 |显示全部楼层
xiaobu888 发表于 2014-7-8 13:39
看来hd4000这个问题目前全球无解啊

我第一次安装笔记本 ,开机前出现的花屏我以为我自己驱动没搞完善才这样呢,原来都这样啊

Rank: 9

UID
752499
帖子
4067
PB币
5328
贡献
0
技术
369
活跃
507

Win10先驱者

发表于 2014-7-8 15:02:04 |显示全部楼层
楼主需要一个无线网卡,不过Dell比较良心没有白名单。

Rank: 7Rank: 7Rank: 7

UID
678781
帖子
1478
PB币
0
贡献
0
技术
14
活跃
1076

活动参与先锋 8周年庆典勋章

发表于 2014-7-8 16:49:34 |显示全部楼层
请问你一个问题,我把bios升级到A12,进系统,是花屏的,你的有没有这个问题

Rank: 5Rank: 5Rank: 5

UID
334746
帖子
848
PB币
2885
贡献
0
技术
6
活跃
1201
发表于 2014-7-8 17:23:53 |显示全部楼层
我这边有个本子,V480S,只能正常安装10.8.5,之后的10.9和10.10全部都会卡到一个地方,蓝牙驱动删除后,也会卡,菊花转半天然后就死了
折腾了一周都没好,最后只好死守ML了

Rank: 7Rank: 7Rank: 7

UID
501120
帖子
2590
PB币
4678
贡献
0
技术
234
活跃
1164
发表于 2014-7-8 17:27:51 |显示全部楼层
zhanglei138099 发表于 2014-7-8 16:49
请问你一个问题,我把bios升级到A12,进系统,是花屏的,你的有没有这个问题

开机后进桌面前1-2秒的花屏后显示桌面 ,其他不花屏 , 开机前花屏是HD4000的通病

Rank: 7Rank: 7Rank: 7

UID
501120
帖子
2590
PB币
4678
贡献
0
技术
234
活跃
1164
发表于 2014-7-8 17:29:12 |显示全部楼层
melxman 发表于 2014-7-8 17:23
我这边有个本子,V480S,只能正常安装10.8.5,之后的10.9和10.10全部都会卡到一个地方,蓝牙驱动删除后,也 ...

卡在蓝牙那里不是蓝牙驱动问题,是显卡问题

Rank: 7Rank: 7Rank: 7

UID
501120
帖子
2590
PB币
4678
贡献
0
技术
234
活跃
1164
发表于 2014-7-8 17:31:18 |显示全部楼层
tmacyunn 发表于 2014-7-8 15:02
楼主需要一个无线网卡,不过Dell比较良心没有白名单。

找资料都说自带的wifi全球无解,  没事的,我这笔记本只是想看看10.10

Rank: 5Rank: 5Rank: 5

UID
334746
帖子
848
PB币
2885
贡献
0
技术
6
活跃
1201
发表于 2014-7-9 06:23:31 来自手机 |显示全部楼层
hasimu 发表于 2014-7-8 17:29
卡在蓝牙那里不是蓝牙驱动问题,是显卡问题

clover在10.8.5下正常的显卡驱动参数,到了10.9以后就不行。太郁闷了

Rank: 7Rank: 7Rank: 7

UID
501120
帖子
2590
PB币
4678
贡献
0
技术
234
活跃
1164
发表于 2014-7-9 13:46:18 来自手机 |显示全部楼层
melxman 发表于 2014-7-9 06:23
clover在10.8.5下正常的显卡驱动参数,到了10.9以后就不行。太郁闷了

你clover怎么驱动的显卡说来听听? 因为10.8时代和10.9时代clover代码参数有很大变化。我怀疑你代码语法错误导致参数没有生效

Rank: 5Rank: 5Rank: 5

UID
334746
帖子
848
PB币
2885
贡献
0
技术
6
活跃
1201
发表于 2014-7-9 14:40:35 |显示全部楼层
本帖最后由 melxman 于 2014-7-9 15:00 编辑
hasimu 发表于 2014-7-9 13:46
你clover怎么驱动的显卡说来听听? 因为10.8时代和10.9时代clover代码参数有很大变化。我怀疑你代码语法错 ...

首先,用的都是27XX版本的clover(一模一样的版本)
其次,在10.8.5时代,用的ig-platform-id+EDID注入驱动的HD4000,3代的笔记本集显(1660003。inject intel,dual link 0或者1无所谓)
smbios用的MBA5.1的
10.9开始,这些一样的参数就开始卡蓝牙(不灰屏),或者是另外的,直接卡死(灰屏,好像是卡到什么  arrived)

Rank: 7Rank: 7Rank: 7

UID
501120
帖子
2590
PB币
4678
贡献
0
技术
234
活跃
1164
发表于 2014-7-9 15:06:59 |显示全部楼层
melxman 发表于 2014-7-9 14:40
首先,用的都是27XX版本的clover(一模一样的版本)
其次,在10.8.5时代,用的ig-platform-id+EDID注入驱动 ...

把你的config发过来看看

Rank: 5Rank: 5Rank: 5

UID
334746
帖子
848
PB币
2885
贡献
0
技术
6
活跃
1201
发表于 2014-7-9 21:23:35 来自手机 |显示全部楼层
hasimu 发表于 2014-7-9 15:06
把你的config发过来看看

等明天早上吧,现在本子没在身边
太感谢你了
回顶部
Copyright (C) 2005-2019 pcbeta.com, All rights reserved
Powered by Discuz!  苏ICP备17027154号
请勿发布违反中华人民共和国法律法规的言论,会员观点不代表远景论坛官方立场。
远景在线 | 远景论坛 | 苹果论坛 | Win10论坛 | Win8论坛 | Win7论坛 | WP论坛 | Office论坛 | 电脑硬件 | 安卓软件