Win10论坛

Win10正式版系统下载主题平板

重定义Modern UI,打造完美Windows全新体验

Windows10下载|安装|新手宝典|必备软件

搜索
楼主: syscl

[教程] 彻底解决开机禁行     [复制链接]

作死党

Rank: 7Rank: 7Rank: 7

UID
4690694
帖子
1309
PB币
218
贡献
0
技术
0
活跃
1238
发表于 2016-4-22 11:02:25 来自手机 |显示全部楼层
a1379388505 发表于 2016-4-22 09:26
标题党!还有随机禁行叫彻底解决吗

我的彻底解决了 没有修改文件就用的最新版

0x40也已经部分关闭sip了
头像被屏蔽

Rank: 2Rank: 2

UID
2672789
帖子
111
PB币
0
贡献
0
技术
0
活跃
131
发表于 2016-4-22 11:10:55 |显示全部楼层
提示: 作者被禁止或删除 内容自动屏蔽

Rank: 5Rank: 5Rank: 5

UID
3474819
帖子
834
PB币
292
贡献
0
技术
5
活跃
1350
发表于 2016-4-22 11:19:30 |显示全部楼层
收藏以备不时之需

Rank: 7Rank: 7Rank: 7

UID
4601497
帖子
1869
PB币
2735
贡献
0
技术
25
活跃
1471
发表于 2016-4-22 11:24:03 |显示全部楼层
大神帮帮忙啊
求大神帮忙制作applealc驱动 | http://bbs.pcbeta.com/forum.php?mod=viewthread&tid=1686899

Rank: 2Rank: 2

UID
911356
帖子
313
PB币
197
贡献
0
技术
0
活跃
669
发表于 2016-4-22 11:24:06 |显示全部楼层
支持这种不断追求完美,不断优化和与大家共同分享的精神

苦逼的医学生。。。考试月勿扰,扣扣一概不回!

Rank: 11Rank: 11Rank: 11

UID
2043294
帖子
4556
PB币
212
贡献
0
技术
150
活跃
2011

7周年庆典勋章 8周年庆典勋章 我是大学生!

发表于 2016-4-22 11:24:54 来自手机 |显示全部楼层
我是BIOS模拟的UEFI,也会出现花屏死机

远景FANS

UID
424619
帖子
4181
PB币
529
贡献
0
技术
741
活跃
2167

巡察使 我是大学生!

发表于 2016-4-22 11:36:42 |显示全部楼层
gujiangjiang 发表于 2016-4-22 11:24
我是BIOS模拟的UEFI,也会出现花屏死机

BIOS模拟UEFI不会出现开机内存分配的问题。

远景FANS

UID
424619
帖子
4181
PB币
529
贡献
0
技术
741
活跃
2167

巡察使 我是大学生!

发表于 2016-4-22 11:38:36 |显示全部楼层
a1379388505 发表于 2016-4-22 09:26
标题党!还有随机禁行叫彻底解决吗

我的彻底解决了 没有修改文件就用的最新版

请看清楚!

随机禁行的是OsxAptioFix2Drv-64.efi. 我修改的是OsxAptioFixDrv-64.efi.



有人讲看到你彼日散步淡水河

Rank: 7Rank: 7Rank: 7

UID
1145658
帖子
1423
PB币
3193
贡献
0
技术
161
活跃
1272
发表于 2016-4-22 11:38:41 |显示全部楼层
膜拜大神

Rank: 7Rank: 7Rank: 7

UID
656272
帖子
1907
PB币
272
贡献
0
技术
225
活跃
1174

Win10先驱者

发表于 2016-4-22 12:04:06 |显示全部楼层
我不要用户名 发表于 2016-4-22 11:02
0x40也已经部分关闭sip了

求解多少是彻底不关闭 多少是彻底关闭 这个远景没有说明呢  国外论坛有  但是我是文盲

Rank: 7Rank: 7Rank: 7

UID
656272
帖子
1907
PB币
272
贡献
0
技术
225
活跃
1174

Win10先驱者

发表于 2016-4-22 12:06:18 |显示全部楼层
gujiangjiang 发表于 2016-4-22 11:24
我是BIOS模拟的UEFI,也会出现花屏死机

你的还没解决?咱俩上次研究的结果我的用起来已经彻底不花屏不冻屏了   卡顿也几乎没有了

作死党

Rank: 7Rank: 7Rank: 7

UID
4690694
帖子
1309
PB币
218
贡献
0
技术
0
活跃
1238
发表于 2016-4-22 12:08:04 |显示全部楼层
a1379388505 发表于 2016-4-22 12:04
求解多少是彻底不关闭 多少是彻底关闭 这个远景没有说明呢  国外论坛有  但是我是文盲

http://bbs.pcbeta.com/viewthread-1605186-1-1.html

谁说没有的= =
1

查看全部评分

苦逼的医学生。。。考试月勿扰,扣扣一概不回!

Rank: 11Rank: 11Rank: 11

UID
2043294
帖子
4556
PB币
212
贡献
0
技术
150
活跃
2011

7周年庆典勋章 8周年庆典勋章 我是大学生!

发表于 2016-4-22 12:08:21 |显示全部楼层
a1379388505 发表于 2016-4-22 12:06
你的还没解决?咱俩上次研究的结果我的用起来已经彻底不花屏不冻屏了   卡顿也几乎没有了

花屏偶尔还是会有一点点,很少,死机也有过一次,估计还是没解决,你们弄的都是Drv这几个EFI的驱动,但是我用不到这些,我是BIOS模拟的

苦逼的医学生。。。考试月勿扰,扣扣一概不回!

Rank: 11Rank: 11Rank: 11

UID
2043294
帖子
4556
PB币
212
贡献
0
技术
150
活跃
2011

7周年庆典勋章 8周年庆典勋章 我是大学生!

发表于 2016-4-22 12:10:39 |显示全部楼层
syscl 发表于 2016-4-22 11:36
BIOS模拟UEFI不会出现开机内存分配的问题。

但是我的确实出现了升级到了10.11.4之后花屏死机的问题,之前一直用slide=0完美解决了,现在这个flag已经失效了,我再csr里面添加了0X40,好像暂时没什么大的问题,但是之前还是死机过一次,估计问题还是没有解决。

远景FANS

UID
424619
帖子
4181
PB币
529
贡献
0
技术
741
活跃
2167

巡察使 我是大学生!

发表于 2016-4-22 12:17:29 |显示全部楼层
gujiangjiang 发表于 2016-4-22 12:10
但是我的确实出现了升级到了10.11.4之后花屏死机的问题,之前一直用slide=0完美解决了,现在这个flag已经 ...

这个我没有HD3000的机型,所以没有办法帮你解决哎。你的花屏是怎样的情况呢?

不过你可以试一下CsmVideo那个驱动,我是利用那个驱动加上分辨率解决HD4000花屏的问题的。

Slide=XX这个argv很奇怪,昨天去问Aptio的其中一个开发者说这个slide和Aptio没有关系(但是其他人反馈我给的参数确实有效), 所以可能还需要进一步的探讨.

Rank: 7Rank: 7Rank: 7

UID
656272
帖子
1907
PB币
272
贡献
0
技术
225
活跃
1174

Win10先驱者

发表于 2016-4-22 12:25:52 |显示全部楼层
syscl 发表于 2016-4-22 11:38
请看清楚!

随机禁行的是OsxAptioFix2Drv-64.efi. 我修改的是OsxAptioFixDrv-64.efi.

CsrActiveConfig我设置0x40 就完美了 不知道跟67什么区别 求资料 给个链接也行

远景FANS

UID
424619
帖子
4181
PB币
529
贡献
0
技术
741
活跃
2167

巡察使 我是大学生!

发表于 2016-4-22 12:31:05 |显示全部楼层
a1379388505 发表于 2016-4-22 12:25
CsrActiveConfig我设置0x40 就完美了 不知道跟67什么区别 求资料 给个链接也行

如果设置成0x40就完美了,那就停留在那个值上面吧。

我没用过0x40, 但是国外论坛说这个数值解决了花屏的问题. 我之前也没有关注过0x67, 直到10.11.4才开始关注, IM上面也众说纷纭, 一个解释就是SIP大一点的数值禁用了更多的SIP功能, 导致kernel对内存空间的分配减少. 但是开发者的态度是"odd"(奇怪的现象).

Rank: 7Rank: 7Rank: 7

UID
656272
帖子
1907
PB币
272
贡献
0
技术
225
活跃
1174

Win10先驱者

发表于 2016-4-22 12:32:07 |显示全部楼层
syscl 发表于 2016-4-22 12:17
这个我没有HD3000的机型,所以没有办法帮你解决哎。你的花屏是怎样的情况呢?

不过你可以试一下CsmVide ...

我跟他的一样问题,以前也一样用的OsxAptioFix2Drv-64.efi+slide=0 就不花屏不死机 不加slide=0就花屏死机
后来也不知道是升级了11.4还是升级了clover导致的 这个参数无效了
最后用的跟你文中讲的禁行方法一样的处理 只不过我没修改OsxAptioFixDrv-64.efi,CsrActiveConfig设置的0x40
就不卡顿 花屏 死机了 还意外的解决了随机禁行

远景FANS

UID
424619
帖子
4181
PB币
529
贡献
0
技术
741
活跃
2167

巡察使 我是大学生!

发表于 2016-4-22 12:41:54 |显示全部楼层
a1379388505 发表于 2016-4-22 12:32
我跟他的一样问题,以前也一样用的OsxAptioFix2Drv-64.efi+slide=0 就不花屏不死机 不加slide=0就花屏 ...

r3468提高了OsxAptioFixDrv-64.efi的relocation size(96MB-->128MB), 但是这个数值对某些机型, 某些内核扩展来说还是不够大, 所以我提高到256MB, 目前来说, 这个数值已经足够大了.

slide这个参数, 也是众说纷纭, 昨天一个老外给我的反馈就是大数值slide=8000确实有效, 能够解Fix2的启动问题, 但是, 其中一个作者告诉我AptioFix2其实和slide没有关系, 也就改变了论坛里面一直以为slide和Fix2必须配对使用的误区, 后来查Apple的文档发现slide参数本来就是mach_kernel的参数, 设置更大的数值可能能改善随机禁行的问题, 但是不能彻底解决(在H67-M 上面即便有时候设置slide=16000也没有用). 但是Without caches + slide=XX能够稍微缓解.

在出现随机禁行的机型中, 可能用AptioFix1是最稳妥的做法.

苦逼的医学生。。。考试月勿扰,扣扣一概不回!

Rank: 11Rank: 11Rank: 11

UID
2043294
帖子
4556
PB币
212
贡献
0
技术
150
活跃
2011

7周年庆典勋章 8周年庆典勋章 我是大学生!

发表于 2016-4-22 12:42:37 |显示全部楼层
syscl 发表于 2016-4-22 12:17
这个我没有HD3000的机型,所以没有办法帮你解决哎。你的花屏是怎样的情况呢?

不过你可以试一下CsmVide ...

就是很普通的那种花屏,在观看Flash视频、浏览网页,或者内存占用达到99%的时候,就会出现一些白色斑块,或者黑色横线,花屏之后没多久就是定屏,也就是除了鼠标可以动以外,其他所有的活动都停止了,硬盘也不读写了,只能通过强行关机解决。

在10.8到10.11.3的系统一直可以用slide=0解决这个问题,据说是解决了内存分配的问题,但是升级到10.11.4之后不行了,添加了也没用,我还尝试过slide=50,slide=150,dart=0等都无济于事。

前两天看到有个帖子讨论这个问题,我尝试着改了csr为0X40,发现目前情况好多了,这么多天就出现了一次小花屏,还出现过一次死机,其他情况下都还保持稳定。

看到你们都在讨论EFI驱动的问题,但问题是我不是UEFI啊,我是Clover模拟的EFI,应该用不到这几个驱动的,但是我的问题是存在的,所以想问问你们。

我在国外网站发过帖子,不过没人理睬,可能我的英文比较差吧。
关闭

站长推荐

已经开启实名认证了哟
这里可以进行实名操作:点我点我点我
回顶部
Copyright (C) 2005-2019 pcbeta.com, All rights reserved
Powered by Discuz!  苏ICP备17027154号
请勿发布违反中华人民共和国法律法规的言论,会员观点不代表远景论坛官方立场。
远景在线 | 远景论坛 | 苹果论坛 | Win10论坛 | Win8论坛 | Win7论坛 | WP论坛 | Office论坛 | 电脑硬件 | 安卓软件