Win10论坛

Win10正式版系统下载主题平板

重定义Modern UI,打造完美Windows全新体验

Windows10下载|安装|新手宝典|必备软件

搜索
查看: 4712|回复: 31

[其它] 疑难杂症,磁盘工具找不到硬盘,卡在这步三天了 [复制链接]

Rank: 1

UID
4845798
帖子
75
PB币
1
贡献
0
技术
0
活跃
293
发表于 2018-11-7 12:50:38 |显示全部楼层
PE、BIOS下能看到SSD(能顺利安装win10)10.14.1进入安装界面时,磁盘工具找不到硬盘,只识别到了U盘
由于主板原因,sata和usb都只有2.0
以前能顺利安装10.12.6,现在也不行了,同样的硬件没有变更(加了个BCM943602CS网卡)
能百度来的方法都试过了,论坛大佬多,求大佬帮忙看一下

已尝试:(无效指磁盘工具找不到硬盘)
开启关闭AHCI,无效
SSD转换为GUID,无效
SSD转换为MBR,无效
SSD格式化为NTFSorFAT32,无效
将efi和kext文件升级到最新,无效
VBoxHfs-64替换为HFSplus-64,无效
加入HTFS-64,无效
镜像换为10.12.6,无效
加入SATA-100-series-unsupported.kext,无效
加入DataHubDxe、SMCHelper、EmuVariableUefi、Fat、NvmExpressDxe、OsxFatBinaryDrv、PartitionDxe,无效
尝试每一个sata接口,无效

下面是配置
主板:技嘉H61M-DS2 REV2.2 初始BIOS版本7(已刷为F8K)
CPU:奔腾G2030
显卡:影驰 虎将 GT730 1G DDR5
无线网卡:BCM943602CS
SSD:淘宝买的杂牌128G SSD
Clover版本:v2.4k r4722

drivers64UEFI : apfsDriverLoader-64、AptioMemoryFix-64、FSInject-64、VBoxHfs-64
kext\Other : AppleALC、FakeSMC、Lilu、RealtekRT81xx、USBInjectAll、VoodooPS2Comtroller
efi和kext文件均为最新


BIOS设置:
OS Type:windows 8
启动CSM:从不
Secure Boot:关闭
SATA模式选择:AHCI模式
支持传统USB规格设备:开启
EHCI Hand-off:开启

我觉得有可能是efi文件的问题,毕竟前一阵子10.12.6能安装(同一个镜像),可是不知道是哪个的问题,能更新的都更新了
天天下班回家弄到凌晨1两点,醉了

Rank: 5Rank: 5Rank: 5

UID
4490716
帖子
515
PB币
390
贡献
0
技术
38
活跃
608
发表于 2018-11-7 13:22:38 |显示全部楼层
Paragon Hard Disk Manager
推荐用这个工具win下先将ssd格式化为hfs格式 ,然后再安装mac 。

Rank: 5Rank: 5Rank: 5

UID
1115891
帖子
482
PB币
87
贡献
0
技术
1
活跃
479
发表于 2018-11-7 13:22:45 |显示全部楼层
重新写镜像到U盘安装,同一个系统,我写到三个优盘里面,总是有一个优盘有问题。

Rank: 2Rank: 2

UID
4828517
帖子
344
PB币
354
贡献
0
技术
0
活跃
340
发表于 2018-11-7 13:26:05 |显示全部楼层
如果是nvme,需要在config里加10.14的nvme补丁,补丁论坛里有
http://bbs.pcbeta.com/viewthread-1774117-1-1.html

Rank: 1

UID
4845798
帖子
75
PB币
1
贡献
0
技术
0
活跃
293
发表于 2018-11-7 13:26:18 |显示全部楼层

Rank: 1

UID
4845798
帖子
75
PB币
1
贡献
0
技术
0
活跃
293
发表于 2018-11-7 13:27:27 |显示全部楼层
D.Rose 发表于 2018-11-7 13:26
如果是nvme,需要在config里加10.14的nvme补丁,补丁论坛里有
http://bbs.pcbeta.com/viewthread-1774117-1- ...

走的sata2.0,上面说了

Rank: 1

UID
4845798
帖子
75
PB币
1
贡献
0
技术
0
活跃
293
发表于 2018-11-7 13:28:02 |显示全部楼层
shineey 发表于 2018-11-7 13:22
推荐用这个工具win下先将ssd格式化为hfs格式 ,然后再安装mac 。

好的老哥,晚上我回去试试

Rank: 1

UID
4845798
帖子
75
PB币
1
贡献
0
技术
0
活跃
293
发表于 2018-11-7 13:28:35 |显示全部楼层
风间雨月 发表于 2018-11-7 13:22
重新写镜像到U盘安装,同一个系统,我写到三个优盘里面,总是有一个优盘有问题。

试过两个U盘,都不行

Rank: 1

UID
3287170
帖子
36
PB币
123
贡献
0
技术
0
活跃
86
发表于 2018-11-7 14:00:49 |显示全部楼层
有这个补丁吗?
附件: 你需要登录才可以下载或查看附件。没有帐号?注册

Rank: 2Rank: 2

UID
120544
帖子
460
PB币
1127
贡献
0
技术
30
活跃
1248
发表于 2018-11-7 14:12:52 |显示全部楼层
根据你的描述,clover启动界面应该就看不到硬盘。找AHCI_3rdParty_SATA.kext、AHCI_Intel_Generic_SATA.kext、SATA-200-series-unsupported.kext,放到other里

Rank: 1

UID
4845798
帖子
75
PB币
1
贡献
0
技术
0
活跃
293
发表于 2018-11-7 14:22:32 |显示全部楼层
clickmed 发表于 2018-11-7 14:12
根据你的描述,clover启动界面应该就看不到硬盘。找AHCI_3rdParty_SATA.kext、AHCI_Intel_Generic_SATA.kex ...

clover启动界面能看见硬盘,顺利进入安装界面然后找不到硬盘

Rank: 1

UID
4845798
帖子
75
PB币
1
贡献
0
技术
0
活跃
293
发表于 2018-11-7 14:25:17 |显示全部楼层
yjs0371 发表于 2018-11-7 14:00
有这个补丁吗?

没试过,老哥求附件

Rank: 2Rank: 2

UID
4808381
帖子
226
PB币
2
贡献
0
技术
0
活跃
363
发表于 2018-11-7 15:30:31 |显示全部楼层
可能是是分配ESP不能少于300M 大一点没关系

Rank: 1

UID
3287170
帖子
36
PB币
123
贡献
0
技术
0
活跃
86
发表于 2018-11-7 16:06:48 |显示全部楼层
Byli 发表于 2018-11-7 14:25
没试过,老哥求附件

AppleAHCIPort
4585F60F 95C289C8 83E0FE66 85C9780F 84D2750B
89C883E0 FE6685C9 0F98C141 08CC9090 9090750B
Fix I/O error for ICH10

看上面图按照位置写入试试看

Rank: 1

UID
4845798
帖子
75
PB币
1
贡献
0
技术
0
活跃
293
发表于 2018-11-7 17:04:11 |显示全部楼层
hxcsjhy 发表于 2018-11-7 15:30
可能是是分配ESP不能少于300M 大一点没关系

也试过了没用

Rank: 5Rank: 5Rank: 5

UID
2900519
帖子
580
PB币
1112
贡献
0
技术
0
活跃
846
发表于 2018-11-7 17:07:34 |显示全部楼层
辣鸡台式机没有这方面的困扰

Rank: 5Rank: 5Rank: 5

UID
718853
帖子
514
PB币
7
贡献
0
技术
5
活跃
1197
发表于 2018-11-7 17:17:40 |显示全部楼层
建议你重新下个小兵的镜像

Rank: 7Rank: 7Rank: 7

UID
1048529
帖子
1179
PB币
1238
贡献
0
技术
1
活跃
1282
发表于 2018-11-7 17:44:23 |显示全部楼层
本帖最后由 Hunck 于 2018-11-7 17:48 编辑

請在clover other 裡面加入
AHCIPortInjector.kext
IOAHCIBlockStorageInjector.kext

IOAHCIBlockStorageInjector  這個可以晚點裝試看看AHCIPortInjector.kext放到clover裡面

good luck
附件: 你需要登录才可以下载或查看附件。没有帐号?注册

Rank: 1

UID
4845798
帖子
75
PB币
1
贡献
0
技术
0
活跃
293
发表于 2018-11-7 20:46:34 |显示全部楼层
Hunck 发表于 2018-11-7 17:44
請在clover other 裡面加入
AHCIPortInjector.kext
IOAHCIBlockStorageInjector.kext

还是不行

Rank: 1

UID
4845798
帖子
75
PB币
1
贡献
0
技术
0
活跃
293
发表于 2018-11-8 09:07:02 |显示全部楼层
问题解决了,我先格盘安装了WIN10到SSD,并更新主板BIOS版本为10a,成功识别硬盘。由于连续操作,不清楚是安装WIN10自动分区起的作用,还是升级BIOS起的作用(估计是升级BIOS起的作用,但是以前用F8K版本时也能够识别硬盘)附BIOS
附件: 你需要登录才可以下载或查看附件。没有帐号?注册
回顶部
Copyright (C) 2005-2021 pcbeta.com, All rights reserved
Powered by Discuz!  苏ICP备17027154号
请勿发布违反中华人民共和国法律法规的言论,会员观点不代表远景论坛官方立场。
远景在线 | 远景论坛 | 苹果论坛 | Win10论坛 | Win8论坛 | Win7论坛 | WP论坛 | Office论坛 | 电脑硬件 | 安卓软件