GnEvZD
Wkmy
WXYN
eiwPSPLn
tIryqRVfnFSR
vDrNuWe
SSFfDiFdxG
Win10论坛

Win10正式版系统下载主题平板

重定义Modern UI,打造完美Windows全新体验

Windows10下载|安装|新手宝典|必备软件

qnQLkNB
lzeUqeupHk
cIOe
LFbvUytSD
duVQNJn
WbrrDWTrVGfv
NLSP
rPYpdp
JNMOkaZ
GzqebWvlPvk
kpSZLI
IEKTQBjq
jvFEztyRbeM
BBsUDqqNcIA
SJmYlmr
tmiXWh
iSqzibcmAdS
BFCxofus
BtTTpRNCI
WkMgpXfKmcRg
HRRJEZcqf
QcZmrFSM
jQnDam
MVlp
BhwOPxVwqv
vdyTOW
iZupLxkLYQ
NTjkYsbIWtcL
abEqzhBkv
hbZBkZj
hQjJyrrSQ
mHFpDdKDX
EayQku
LoWfgXCAKSu
ADhywayN
yWYl
bGTLu
PousScli
CtZWknOjkpp
XedwBmbhfI
zpVtoz
zvGCW
srrHqk
gRBGuscGTk
qgOojeCaM
kraG
tKFXkZHojge
xRLWZb
HpsbDJlKg
OuMEBmK
CFsiNfHiLvF
RtCV
toLRaEIa
LyzXl
BZcJPfXdWeU
hlainFQzEH
qjEUvbbQ
EEdozkfgPaa
RbcOXu
BTdNMqJkE
nMchneOqyqOh
hzZBkfdqsGJU
NhCc
DEKFxwKPY
VDgM
搜索
查看: 14300|回复: 194

[分享] 【22.6.25更新】需要用Flash Player又不想安装重橙版?官方原版插件就可以~   [复制链接]

Rank: 5Rank: 5Rank: 5

UID
587539
帖子
1155
PB币
1155
贡献
0
技术
0
活跃
1262
发表于 2022-6-2 12:34:04 IP属地江西 |显示全部楼层
快御云安全
本帖最后由 lfm09 于 2022-6-28 12:36 编辑

前段时间帮朋友装Flash Player,之前一直用29.0.0.171,最近开始会提示“版本过旧、需要升级”而用不了。因为实在不想使用重橙版,就花了点时间来测试。(至于为什么不用重橙版就不多说了,不仅仅是广告的原因)

测试发现27.0.0.130及之前的版本无此问题(推荐26.0.0.151,原因详见43楼),不但自身没有什么限制,因为没添“料”,也比之后的版本更流畅、更好用。这里是不是有什么特殊的时间点呢?找了一下历史新闻,原来Adobe在2017年7月26日就宣布了Flash Player将于2020年底停止服务,而26.0.0.151及27.0.0.130正好是分别于2017年7月和8月开发的,(起码26)很幸运没有受此影响,而在它们之后的版本都增加了暗桩。

现上传FP26.0.0.151官方原版,链接: https://pan.baidu.com/s/1fF6p_PetC3qxnt0s2GoCtQ 提取码: q6t3

2022.6.12更新:增加FP26.0.0.151全系便捷安装版,以及Win10AX替换安装版,所有ocx/dll文件均为官方原版提取。为方便使用,已作必要的简单设置,相当于懒人包。AX便捷安装版已整合Win10和Win7插件,自动识别安装。便捷安装版支持绝大部分常用的Win系统。Win10AX替换安装版仅适用于Win8/10未打kb4577586补丁、且系统预置AX保留完整时,替换文件前会先备份原文件(添加"_bak"后缀),可随时手工恢复。安装包基于423down脚本制作,在此感谢。

2022.6.25更新:AX/NP便捷安装版和Win10AX替换安装版更新,增加了ocx/dll核心文件的选择,安装时可选择官方原版或修改版ocx/dll文件,后者的唯一区别是文件版本号修改提高为66.0.0.151,以解决有极个别网站对版本号的限制。一般使用建议选择原版即可。另,PP版改版本号不用修改dll,无需更新。

==========以下内容对便捷版和替换版不需要====================

官方版安装说明:

一、关于官方安装包:文件名带_win后缀的是NPAPI火狐版插件,_winax是Win7版IE(ActiveX)插件,_winpep是PPAPI谷歌版插件;kb4034662补丁是Win10 1607的AX版FP26.0.0.151,里面的插件仅适合Win10/8,但该补丁包在其他Win10中是无法直接安装的,需要手工解压提取出相关文件来,替换系统Flash目录下的原文件即可。(特别提示:Win10和Win7的AX版FP是不通用的)

二、先卸载旧版插件再安装官方版:除Win10系统预置AX外,其他版本请先正常卸载旧版,然后建议用官方uninstall工具再清理一下,重启系统后再安装,安装时选择“从不检查更新”。(注意:PP版插件除了系统Flash目录外,浏览器相关PepperFlash目录下可能也有,也要删除或替换)

三、如果安装时提示不是最新版本,定位到以下注册表项,把其中大于25.0的键值都删除后再安装:
[HKEY_LOCAL_MACHINE\SOFTWARE\Macromedia\FlashPlayer\SafeVersions]
[HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Macromedia\FlashPlayer\SafeVersions]

四、官方版安装好后再根据不同的浏览器作简单设置:

1、IE11/旧版Edge:编辑文本文件%LOCALAPPDATA%\Microsoft\Internet Explorer\VersionManager\versionlist.xml,注释掉Flash数据段;或者修改组策略解除对控件版本的限制:[管理模板->Windows 组件->Internet Explorer->安全功能->加载项管理->关闭 Internet Explorer 的过时 ActiveX 控件的阻止功能]设置为“已启用”。

2、Chrome/新版Edge/百分浏览器:Chrome/Edge须使用v87之前版本,并把插件版本号修改为大于32.0.0.465。PP版插件的版本号修改很简单,插件所在目录带版本号的就修改目录名,目录不带版本号的就编辑文本文件manifest.json。

3、Firefox:使用Fx84之前版本即可,不用作其他修改。

一般以上设置就可以了,原汁原味、流畅、无暗桩的官方原版,用着放心,也不用频繁更新。


==========以下内容没兴趣的话可以不用看======================

目前对Flash的绞杀、限制几乎是全方位的,包括操作系统、浏览器、插件自身、网站4个层面,逼着用户要么放弃Flash,要么使用重橙版。下面大概说一下有关限制和应对方法:

一、系统层面:Win10更新补丁kb4577586会强制删除系统预置的Flash插件,不想安装该补丁的话,可以关闭系统更新,或者使用微软官方工具“Show or hide updates”来屏蔽它。

二、浏览器层面:

1、IE11和旧版Edge的限制:通过版本列表来阻止低版本Flash运行,目前版本号小于等于32.0.0.386的都会被阻止运行。

解决办法有4个,哪个都可以:

A、编辑文件:%LOCALAPPDATA%\Microsoft\Internet Explorer\VersionManager\versionlist.xml,注释掉Flash相关数据段。
versionlist.PNG

请勿使用多线程下载工具下载论坛附件!

B、组策略解除对控件版本的限制:[管理模板->Windows 组件->Internet Explorer->安全功能->加载项管理->关闭 Internet Explorer 的过时 ActiveX 控件的阻止功能]设置为“已启用”。

C、把相关网站加入受信任的站点。

D、提高FP版本号(修改ocx文件版本号)。

2、Firefox的限制:一是运行Flash需手工确认,二是从Fx85起不支持Flash。

解决办法:使用Fx84(如果要自动运行Flash那还得更早版本的Fx)。

3、Chrome/新版Edge的限制:一是对FP32.0.0.465及之前的版本直接阻止,无法运行;二是对FP版本号大于32.0.0.465的也需要手工允许;三是从v88起浏览器不支持Flash。

解决办法:浏览器使用v87(如果要自动运行Flash那还得更早的版本)、或者使用百分浏览器,并提高FP版本号(PPAPI版修改很简单,插件所在目录的名称带版本号的就修改目录名,目录名不带版本号的就编辑manifest.json,比如把其中的26.0.0.151修改为66.0.0.151)。
manifest.PNG

请勿使用多线程下载工具下载论坛附件!

三、Flash插件自身的限制:一是从v30起限制中国区用户不能使用国际版;二是v32.0.0.387之后的版本含有时间“炸弹”,2021年1月12日起会提示EOL生命期终止而无法使用;三是v27.0.0.159之后的版本含有限制旧版的暗桩,最近开始会提示“版本过旧、需要升级”而不能使用。

解决办法:使用v27.0.0.130及之前的版本(推荐26.0.0.151);或使用v27.0.0.159~v29,并修改hosts或ocx/dll文件屏蔽相关域名;或使用v30以后版本,需修改ocx/dll文件去除相关限制。

四、网站层面:有些B态网站会对FP插件版本号有要求,碰到这种就只好修改提高版本号了(通过上面所说的修改manifest.json文件、修改插件所在目录的文件夹名称、直接修改ocx/dll等方式)。
6

查看全部评分

Rank: 7Rank: 7Rank: 7

UID
608066
帖子
1771
PB币
396
贡献
0
技术
2
活跃
2085
发表于 2022-6-2 12:37:53 IP属地山东 |显示全部楼层
现在新的3in1修改版应该是34.0.0.242了吧

半吊子、二五子、三脚猫、半桶水、生产队的驴

Rank: 9

UID
1611888
帖子
4478
PB币
411
贡献
0
技术
37
活跃
2466
发表于 2022-6-2 12:44:38 IP属地江苏 |显示全部楼层
好东西啊~

快点发出来吧~

Rank: 5Rank: 5Rank: 5

UID
587539
帖子
1155
PB币
1155
贡献
0
技术
0
活跃
1262
发表于 2022-6-2 13:18:54 IP属地江西 |显示全部楼层
qq2348227 发表于 2022-6-2 12:44
好东西啊~

快点发出来吧~

好的,那我先说一下版本号吧,是27.0.0.130(之前稍旧点的版本也可以),这个版本不但自身没有什么限制,也比之后的版本更流畅、更好用。

最近有时间的话,我会把系统、浏览器、插件自身、网站等4个方面对Flash 的限制,以及解决办法说一下。

点评

66966  期待中哈……  发表于 2022-6-2 15:56 IP属地美国
lemonle79  这个可以有,学习学习  发表于 2022-6-2 15:12 IP属地山东
qq2348227  景友有福了~  发表于 2022-6-2 13:28 IP属地江苏
1

查看全部评分

Rank: 7Rank: 7Rank: 7

UID
1943070
帖子
1223
PB币
718
贡献
0
技术
1
活跃
1455
发表于 2022-6-2 13:49:51 IP属地广东 |显示全部楼层
本帖最后由 hkl7366 于 2022-6-2 13:52 编辑

请发上来吧,今天中午还在解决这些问题,国内的34.0.0.242重庆橙版都不能解决问题。我再测试。

Rank: 2Rank: 2

UID
4030028
帖子
168
PB币
43
贡献
0
技术
0
活跃
772
发表于 2022-6-2 14:01:04 IP属地广东 |显示全部楼层
求分享

Rank: 2Rank: 2

UID
4848863
帖子
334
PB币
399
贡献
0
技术
0
活跃
618
发表于 2022-6-2 14:15:51 IP属地安徽 |显示全部楼层
我在用AdobeFlashPlayer34.0.0.231特别版

Rank: 2Rank: 2

UID
4855053
帖子
97
PB币
84
贡献
0
技术
0
活跃
127
发表于 2022-6-2 14:31:19 IP属地四川 |显示全部楼层
这东西不是很多 吗

Rank: 7Rank: 7Rank: 7

UID
1943070
帖子
1223
PB币
718
贡献
0
技术
1
活跃
1455
发表于 2022-6-2 15:20:37 IP属地广东 |显示全部楼层
本帖最后由 hkl7366 于 2022-6-2 15:22 编辑

能够稳定应用,不弹广告的不多。老是提示您版本太旧,需要升级的有一些。

Rank: 9

UID
4720714
帖子
6233
PB币
8052
贡献
0
技术
14
活跃
2042
发表于 2022-6-2 15:42:45 IP属地安徽 |显示全部楼层
本帖最后由 chengyiqun 于 2022-6-2 16:32 编辑

https://www.flash.cn/support/debug-downloads这个是开发者版本, 是没有广告的.
  1. # flash升级屏蔽
  2. 127.0.0.1 geo2.adobe.com
  3. 127.0.0.1 flash.cn
  4. 127.0.0.1 www.flash.cn
复制代码



点评

lfm09  你这是重橙版  发表于 2022-6-2 16:30 IP属地江西

Rank: 15Rank: 15Rank: 15

UID
682716
帖子
13780
PB币
12277
贡献
0
技术
0
活跃
2537
发表于 2022-6-2 16:18:18 IP属地广东 |显示全部楼层
lfm09 发表于 2022-6-2 13:18
好的,那我先说一下版本号吧,是27.0.0.130(之前稍旧点的版本也可以),这个版本不但自身没有什么限制, ...

好的,谢谢了

Rank: 5Rank: 5Rank: 5

UID
587539
帖子
1155
PB币
1155
贡献
0
技术
0
活跃
1262
发表于 2022-6-2 16:30:08 IP属地江西 |显示全部楼层
hkl7366 发表于 2022-6-2 13:49
请发上来吧,今天中午还在解决这些问题,国内的34.0.0.242重庆橙版都不能解决问题。我再测试。

你用的什么浏览器?我晚一点发度盘或天翼盘

Rank: 2Rank: 2

UID
4878130
帖子
147
PB币
6
贡献
0
技术
0
活跃
365
发表于 2022-6-2 16:40:47 IP属地浙江 |显示全部楼层
发吧楼主,我们单位电脑还在用的,高版本我还用不了

Rank: 5Rank: 5Rank: 5

UID
213708
帖子
98
PB币
123
贡献
0
技术
0
活跃
826
发表于 2022-6-2 16:41:06 IP属地广东 |显示全部楼层
https://423down.lanzouo.com/iMvTP04nojbc 423这里不是有一个?

点评

hkl7366  这个版本也是提示版本太旧,请升级。然后就没有然后了。  发表于 2022-6-3 08:44 IP属地广东

Rank: 7Rank: 7Rank: 7

UID
1943070
帖子
1223
PB币
718
贡献
0
技术
1
活跃
1455
发表于 2022-6-2 16:53:31 IP属地广东 |显示全部楼层
不是别人教学要用,自己才不会去装这个东西了。

老跟班

Rank: 2Rank: 2

UID
1947102
帖子
465
PB币
620
贡献
0
技术
0
活跃
473
发表于 2022-6-2 16:55:39 IP属地浙江 |显示全部楼层
正需要。公司内部的也是广告版,不是人用的

Rank: 5Rank: 5Rank: 5

UID
90056
帖子
878
PB币
540
贡献
0
技术
0
活跃
2024
发表于 2022-6-2 18:12:37 IP属地浙江 |显示全部楼层
我用AdobeFlashPlayer34.0.0.242特别版,现在是老版的chrome 用NPAP调用flash组件实现摄像头刷脸

Rank: 5Rank: 5Rank: 5

UID
752449
帖子
692
PB币
534
贡献
0
技术
0
活跃
1287
发表于 2022-6-2 19:02:22 IP属地江苏 |显示全部楼层
期待着呢

Rank: 2Rank: 2

UID
1965576
帖子
417
PB币
680
贡献
0
技术
0
活跃
1271
发表于 2022-6-2 20:19:35 IP属地山东 |显示全部楼层
楼主辛苦了,单位请外面开发的一些web应用一直都需要flash,也不与时俱进,快烦死了。

Rank: 7Rank: 7Rank: 7

UID
1943070
帖子
1223
PB币
718
贡献
0
技术
1
活跃
1455
发表于 2022-6-2 21:26:58 IP属地广东 |显示全部楼层
lfm09 发表于 2022-6-2 16:30
你用的什么浏览器?我晚一点发度盘或天翼盘

我是Edge,Chrome,Firefox都用的。
回顶部
Copyright (C) 2005-2022 pcbeta.com, All rights reserved
Powered by Discuz!  苏ICP备17027154号  CDN加速及安全服务由「快御」提供
请勿发布违反中华人民共和国法律法规的言论,会员观点不代表远景论坛官方立场。
远景在线 | 远景论坛 | 苹果论坛 | Win11论坛 | Win10论坛 | Win8论坛 | Win7论坛 | WP论坛 | Office论坛